Jump to content
Head Guru

Php5 / Mysql5 Upgrades

Recommended Posts

I just noticed that I cannot update my Mambo site anymore because of this change. (It produces a database error that I learnt is because my Mambo site doesn't support MySQL 5.

 

Is there any way to roll back to the previous version that works?

Share this post


Link to post
Share on other sites

Welcome to the forums hantms :)

 

Unfortunately the answer to roll back to php4 is no, it's not possible without purchasing your own dedicated server.

Share this post


Link to post
Share on other sites

Welcome, hantms!

Share this post


Link to post
Share on other sites
I just noticed that I cannot update my Mambo site anymore because of this change. (It produces a database error that I learnt is because my Mambo site doesn't support MySQL 5.

 

Is there any way to roll back to the previous version that works?

 

Someone please correct me if I am wrong, but I believe the latest version of Mambo is compatible with PHP5/MySQL5.

Share this post


Link to post
Share on other sites

Dick, you are correct:

 

For security, it is advisable to use PHP 4.4.x versions or higher.

 

Mambo has been tested on MySQL 4.x and 5.x versions. At this time, Mambo does not run in Strict Mode on MySQL 5.x.

 

Taken from the the Mambo requirements page

Share this post


Link to post
Share on other sites

Thanks everyone, I did some research on the Mambo forums and it turns out that there are 2 simple edits in the PHP code that will make Mambo version 4.5.2 and 4.5.3 compatible with MySQL 5.

 

For reference I inlude the link with the solution in case anyone else comes across this issue. (The site in itself works, but there is an issue in one administration panel that's used for updating content) :

 

http://forum.mamboserver.com/showthread.ph...5497&page=5

 

Thanks everyone, also for the warm welcome! ;)

Share this post


Link to post
Share on other sites

×
×
  • Create New...