Jump to content
cjoiner

Odd Character Added To Page Text

Recommended Posts

I need help with an odd character (A) being added to my page text in various places. This happens when I save the page with the HTML editor (wysiwygPro). The page in question is at http://www.giantwarbirds.org/events.htm You can readily see the character added throughout the page.

Any suggestions? I tried to cut and paste the copy from FrontPage and got the same results. I have been editing the pages for months but this problem has started recently.

Share this post


Link to post
Share on other sites

Place this test in your html file where you want the text displayed and it should show up correctly.

 

(A)

Edited by taznumber1

Share this post


Link to post
Share on other sites
Place this test in your html file where you want the text displayed and it should show up correctly. (A)
I don't think cjoiner wants to put (A) in the website, but rather to keep the accented A from being there at all.

 

One possibility is that the file is being uploaded in binary. Try to find the setting to upload it in ASCII and use that and see if it helps. Sorry, I've not used FrontPage in so long I don't remember where the setting is.

Share this post


Link to post
Share on other sites

I looked at the source online and those characters are in the file. To get rid of them you will need to delete them and re-upload the corrected file. I would suggest use use a plain text editor like notepad to delete them.

 

How they got there would be the next question, so you can prevent this from happening again. Those are probably some type of control codes used in one of the programs you used to edit the file before you uploaded. It may have been a typo at some point, you meant to type a capital letter and instead of holding the shiftkey+letter you pressed the ctrl+letter which gave you that code (Â).

Share this post


Link to post
Share on other sites
Welcome to the forum, cjoiner :)

 

Ok, I am using the html - wysiwigpro editor provided by TotalChoice. They took it down ahwile back because of a security problem. I only used the text from FrontPage and cut and pasted it into the page using the editor. Same results, as soon as the page is saved the character appears. I have erased everything on the page, typed in new info, and same results. I am getting frustrated with it as I have been editing the pages for about a year on this site with no problems.

 

If it continues, I will cancel the TC "gold hosting" and go elsewhere.

 

Thanks for your information. -CJ

Share this post


Link to post
Share on other sites
I am using the html - wysiwigpro editor provided by TotalChoice. They took it down ahwile back

I must be missing something. What are you using right now to edit files? Like you said, we took that down awhile back. Walk us through your process and we can help.

 

Right now looking at the source file on the server the characters are in there. It would be easy enough to delete them through the text editor in cPanel. No HTML knowledge required, just delete those characters.

Share this post


Link to post
Share on other sites
If it continues, I will cancel the TC "gold hosting" and go elsewhere.

 

And it will continue over on your new Web Hosting company. TCH just provides you with space and bandwidth to host your site, the "code" you use is totally your responsibility. Now its probably something simple and if you hang on some of us (TCH members or TCH staff) may come up with a solution for you.

 

We have already given you one fix, just edit the file with a plain text editor and remove the characters. This is a simple task and easily done.

 

I would suspect, after and explanation of your steps, the problem is between the two programs you are using. These web page creation programs are a way for folks with no HTML training to be able to quickly and easily post profesional looking web pages. But in using them they are using characters and codes that are easily recognize by themselves but not by other programs. When you create the page in one, you need to edit it in the same one. When you copy and paste from one into another you are either loosing some important piece of code or bringing some code over that the other program cannot interpret.

 

Sorry you are having a tough time, hang in there and someone may come up with a better solution if you don't like the ones I've given.

Share this post


Link to post
Share on other sites
I must be missing something. What are you using right now to edit files? Like you said, we took that down awhile back. Walk us through your process and we can help.

 

Right now looking at the source file on the server the characters are in there. It would be easy enough to delete them through the text editor in cPanel. No HTML knowledge required, just delete those characters.

 

OK, I log on to Total Choice, pick the file I want to edit, wait for it (the html editor) to load and start editing text in plain English. I believe the problem started when TC put the editor back online recently. Anyway, once I have edited the page, I click save. When I view the page online, the A characters are radomly placed throughout the page, no matter how many times I remove them, they return. I am not using FrontPage, I just tried that to test if the same problem would appear, which it did. thanks.

Share this post


Link to post
Share on other sites

Use File Manager in cPanel, select the file and select Edit File and not the HTML editor. Remove the offending characters and save the file.

Share this post


Link to post
Share on other sites
OK, I log on to Total Choice, pick the file I want to edit, wait for it (the html editor) to load and start editing text in plain English. I believe the problem started when TC put the editor back online recently. Anyway, once I have edited the page, I click save. When I view the page online, the A characters are radomly placed throughout the page, no matter how many times I remove them, they return. I am not using FrontPage, I just tried that to test if the same problem would appear, which it did. thanks.

 

Bruce: I did that earlier today but will try again in a few minutes and get back to you. -- Chris

Share this post


Link to post
Share on other sites

Unfortunately cPanel text editors are not well suited to web page editing. It will work but it's usually much easier just to edit a file on your PC and upload it with one of the free FTP programs.

 

Good luck getting it to work for you. One thing is that when you paste it into the editor, and before you save, check to see if the characters are there. They may be getting pasted there and may even be something innocent like tabs getting interpreted by your browser, the clipboard, the cPanel editor, etc.

Share this post


Link to post
Share on other sites
Bruce: I did that earlier today but will try again in a few minutes and get back to you. -- Chris

 

Much improved this time; I would like to resume using the html editor at some point.

 

Thanks for your help. --CJ

Share this post


Link to post
Share on other sites
Unfortunately cPanel text editors are not well suited to web page editing. It will work but it's usually much easier just to edit a file on your PC and upload it with one of the free FTP programs.

 

Good luck getting it to work for you. One thing is that when you paste it into the editor, and before you save, check to see if the characters are there. They may be getting pasted there and may even be something innocent like tabs getting interpreted by your browser, the clipboard, the cPanel editor, etc.

 

What is so strange is I have successfully used the html editor thru cpanel without this problem for the past year.

Guess we'll see where it goes from here. Thanks for your comments -CJ

Share this post


Link to post
Share on other sites

Welcoem to the forums Chris :)

 

In the mean time you may want to look at NVU a free wysiwyg editor

that may be close to what you are used to.

Share this post


Link to post
Share on other sites
What is so strange is I have successfully used the html editor thru cpanel without this problem for the past year.

Guess we'll see where it goes from here. Thanks for your comments -CJ

I doubt that it was the HTML editor that stuck that in there. It had to do with your copy/paste function in Frontpage.

 

I'd get NVU as Don suggests if you need a wysiwyg editor.

Share this post


Link to post
Share on other sites

Hi Everyone...

 

This seems to be a common problem that a number of people are running up against. There is a good communication thread on the wysiwygpro site regarding this issue, here is the link:

http://www.wysiwygpro.com/xForum/topic.asp?TOPIC_ID=1399

 

The issue seems to be a character set conflict, and there are several solutions discussed. Here is the last post that seems to be a correction for the issue:

----------------------------- Begin Other Post -----------------------------------

I had the same problem after a cpanel upgrade. I was bewildered, because other programs that use WYSIWYGPro did not have this problem, only the HTML Editor in cpanel's File Manager.

 

I tried several of the (very good) suggestions above with no success. I tried changing all charset and encoding references to utf-8 and then I tried making all of them iso-8859-1... still no good.

 

Then I noticed that if I made an edit using special characters like spanish accents, etc., saved it, then viewed the page in a browser, it was OK. It was only when I opened the file in HTML Editor again, that the strange characters appeared. If I saved, then the strange characters were there when the page was viewed in a browser. If I backed out without saving the file was OK...

 

So the problem (with cpanel's implementation of WYSIWYGPRO, anyway) is on the way into the editor, not as it is saved.

 

So I edited the file:

/usr/local/cpanel/base/3rdparty/Wysiwygpro/template

 

I found the place where it includes editor_class.php and added a line to also include editor_fucntions.php. For example:

 

include_once ('/usr/local/cpanel/base/3rdparty/WysiwygPro/editor_files/editor_class.php');

include_once ('/usr/local/cpanel/base/3rdparty/WysiwygPro/editor_files/editor_functions.php');

 

Then further down, where it inserts the code into the editor with the line:

$editor->set_code($body);

 

I added in a line to use the fixcharacters function before inserting $body into the editor, like this:

$body = fixcharacters($body,'utf-8');

$editor->set_code($body);

 

That cleared everything up for me.

-------------------------- End other post --------------------------

 

But, I have no idea how to get at the "/usr/local/cpanel/base/3rdparty/Wysiwygpro/template" file to make this correction? Maybe one of the TotalChoice support experts can help us with this?

Share this post


Link to post
Share on other sites

Welcome to the forum, fivesparrows. :)

 

I don´t think that file is accessible by the customers and even if the the template was fixed with the above, it would (unfortunately) probably break next time cpanel pushes out an update unless that problem is fixed in that update.

Share this post


Link to post
Share on other sites

Welcome fivesparrows. It looks like WysiwygPro has written a function to go through the entire page and filter out those non-utf8 characters. If you could get that function and all the ones it depends on into a separate file you could probably include it yourself but that may be a lot of work.

 

If I had to guess I'd say that perhaps FP or Windows itself has a setting for international users that is causing the problem by allowing those "special characters" into the source file and then when it reads it they, for some reason, don't make sense and are interpreted as (A)'s.

 

It is a very important clue that they are using a utf-8 filter to fix the problem though.

Share this post


Link to post
Share on other sites

Welcome to the forum, fivesparrows! :)

Share this post


Link to post
Share on other sites

I did a little more looking, and there is an active cpanel bug report on this issue (bug report 1023 on bugzilla.cpanel.net). So, hopefully we will see a fix soon (and not need the scan work-around). The discussion on it indicates that this is a recently introduced bug, cpanel installations rolled back to release 10.8.1-S114 don't experience the problem. So how about it TCH-Thomas, can we get the work-around put in place until cpanel releases a fix?

Share this post


Link to post
Share on other sites

Thomas is a volunteer (customer) and has no control over the contents on the servers.

 

But regardless, cPanel is constantly pushing updates. So even if the techs were to put the work around in place it would only last until the next cPanel update. With over 100 servers I don't think anyone would want the techs spending a whole lot of time on this.

 

There are plenty of HTML editors you can use on your own machine and upload your files to the server. That's how the majority of people handle their web sites. Just my .02 cents.

Share this post


Link to post
Share on other sites

Agrees with Bruce on this.

 

One of the often mentioned WYSIWYG editors is NVU.

 

I have not tried it myself, but those who have says its easy to use.

Share this post


Link to post
Share on other sites

No problem, I understand the issues with making changes like this across the entire server farm... We just have lots of clients parked on our reseller accounts that like to use the tool to make quick/simple web page content updates in-house (they don't use if for any complicated changes or to add new pages). Installing another tool is just not a great option for them. That is why we were hoping that we could make the change ourselves and have it apply to only that client account (or only our reseller account).

 

Are their security risks with the other suggested tool? I like that this one is tied to the cpanel login (so that you are making changes without relaxing file permisisons). Most of the other ones that we have tried caused us to greatly relax file permissions. This recently resulted in a client site being de-faced by a hacker (they replaced the index.htm file), so I am just a bit leary about relaxing file permisisons these days.

 

But thanks again for all of the attention on this one, hopefully we will see a cpanel fix soon.

Share this post


Link to post
Share on other sites

Security risks would be the same. They need a password to access cPanel, they need a password to access FTP to upload. If the password is passed around or compromised you are SOL either way.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...