Jump to content

Preview Pane Not Showing Post For Saved Entries


Recommended Posts

My saved but unpublished posts do not show in my preview pane. I'm seeing my blog template as it should look, but instead of my saved post, it says, "Sorry, no posts matched your criteria." Once it is published, I can see it when modifying the post.

 

I reinstalled WP twice, no change. Everything else works fine.

 

Just so you know, I don't know much of anything about php. The only solution I found on the WP site involved changing the single.php file, but my template doesn't have that file. So I took the single.php file from the default theme, copied into mine, uploaded it, but that only made it worse. :D

 

I don't use categories in this blog - everything goes into General.

 

Any ideas/suggestions? :) I got no response back from my post on the WP site.

 

Thanks much!

Link to post
Share on other sites

Doh. Just read the title of the post.

 

Just to be clear: You write a brand new post, hit "Save" (or "Save and Continue Editing"?), and when you go back into the draft you can't see it in the preview pane. Once you Publish the post, you are able to see it in the preview pane when editing?

Link to post
Share on other sites

*Paul goes out on a limb here...

 

Have you tried looking at your error log to see what file is trying to be called but can't be seen?

 

Heck, it probably doesn't even throw an error. So this probably wouldn't work.

Link to post
Share on other sites

I can't find anything and can't recreate the problem in 2.0.2 or 2.0.1. What did you find on the WP site about changing single.php? All I could find was something about a guy who saves his posts and they disappear completely.

 

*TCH-Tim goes back to waiting for the Wordpress fairy

Link to post
Share on other sites

:)

 

There's a WordPress fairy? Does she come an leave a dollar under your pillow for every post you make to your blog? If so, where do I sign up to be on her route?!?!

Edited by abinidi
Link to post
Share on other sites

Yep, Bruce tried to help me fix it last weekend but no go. I didn't have permalinks set up at all but he had me do so in hopes that it would fix the problem. Then he sent me the files to reinstall which also didn't help.

 

I suspect it has something to do with my template which I've been using since WP1.2 but I wouldn't know where to start looking. Here's what was posted on the WP forums regarding single.php:

 

Does the preview use the index.php template code? If so, then it would seem that I've messed something up when I tried to implement a category listing in the sidebar, as per this post.

 

OK, I found the error and fixed it. :)

 

The Page Preview uses the single.php file from your theme. In trying to get the sidebar to include some category information, I did some tinkering with how the single pages displayed and messed it up.

 

Totally my fault. Ahhh the pain of the school of hard knocks. :D

Link to post
Share on other sites
I would try switching to the default theme. If the issue still persists then you know its not your theme.

 

Oh duhhh...that would be the logical thing to do, wouldn't it? :)

 

Tried, it still had the problem. So nope, not my template.

 

The only plugins I use are SK2 and wp-grins

 

What else could I have screwed up on each installation? I followed the directions on the WP site as religiously as I possibly could.

Link to post
Share on other sites

It works fine on hubby's blog, and I did his upgrade first (less content to have to restore! :) )

 

I just upgraded them last weekend, and 1.5 didn't have this feature. The old way of previewing worked, though.

Edited by bellringr
Link to post
Share on other sites

Here's an idea. Install a fresh copy into another folder. Import the current database into it. If it works, rename your current folder to something else and then name the new folder your current folder.

 

If it's still working delete the old folder and DB.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...