Jump to content

I Hate Dada


TCH-Thomas
 Share

Recommended Posts

1) I set all stuff in config.pm

2) I uploaded dada directory in cgi-bin and renamed it from dada to DADA from a recommendation and placed mail.cgi where it should be.

3) I created a dada_files outside my public_html as I understand I should do from dada instructions.

4) I set all permissions as they are supposed to be according to dada intructions.

5) I go to www.marveassistans.se/cgi-bin/dada/mail.cgi and I get a 404.

 

What am I doing wrong? <_>

Link to comment
Share on other sites

I just used the installation page

http://mojo.skazat.com/installation/

and followed step by step.

 

And the file

public_html/cgi-bin/dada/DADA/config.pm

should have the following changed to suite

$PROGRAM_ROOT_PASSWORD = 'your pass word for dadamail';

$FILES = '/home/cpanelname/dada_files';

$PROGRAM_URL ='http://www.domain.com/cgi-bin/dada/mail.cgi';

 

and

Chmod 755 the mail.cgi scrip

 

and chmod the folder

/home/cpanelname/dada_files to 777

Link to comment
Share on other sites

The script works now.

I understood the instructions wrong and had placed the mail.cgi in wrong folder.

However now I have a new problem with another script...

>Warning: main(cpanelname/phpnews/headlines.php): failed to open stream: No such file or directory in /home/cpanelname/public_html/uppdat.html on line 82

Warning: main(): Failed opening 'cpanelname/phpnews/headlines.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cpanelname/public_html/uppdat.html on line 82

 

Any clues whats wrong with this one? :unsure:

Edited by Jikrantz
Link to comment
Share on other sites

  • 5 months later...
The script works now.

I understood the instructions wrong and had placed the mail.cgi in wrong folder.

 

I am having the exact same experience as described in this thread. I thought I followed the instructions.

 

$FILES = '/home/mysitename/dada_files';

$MAILPROG = '/usr/sbin/sendmail';

$PROGRAM_URL ='http://www.mydomain.org/cgi-bin/dada/mail.cgi';

 

I upload the DADA folder and all contents - ASCII

Set permissions as instructed

Do not see any apparent upper-lower case discrepancies

 

When accessing mail.cgi I receive a 404 error.

 

Having perused several threads with this same question, I am :clapping:

Link to comment
Share on other sites

These are error messages I am receiving:

 

Premature end of script headers: /home/gbulrpdh/public_html/cgi-bin/dada/mail.cgi

File does not exist: /home/gbulrpdh/public_html/www.inssar.org/favicon.ico

 

favicon.ico exists, but it's up a couple levels in the directory tree.

It appears I have a configuration issue.

 

Is Dada Mail that much better than Mail Man?

Link to comment
Share on other sites

Pocketman, I never used Dada mail extensively, but I belive they serve different purposes. Dada Mail is more geared towards announcements mailing-lists (i.e., the mailing list owner sends e-mail messages to everyone on the list but list members can't send messages to each other). Mailman on the other hamd is a fully-featured mailing-list software, allowing everyone to participate in the discussions. Imagine these forums but instead of you having to visit the forums via your browser, you'd receive all new posts and post your messages via e-mail.

 

Someone correct me if I'm wrong about Dada if but I think that's pretty much it.

 

Hope it helps :)

Link to comment
Share on other sites

No problem :xmas:

 

Just in case you haven't seen it yet, cPanel has Mailman installed for you, so there's no need to go through the nightmare of setting it up yourself, just create the mailing lists, configure their options and you're all set B)

Link to comment
Share on other sites

  • 1 year later...

Seems this post went around about a year and half ago, but I'm coming into these problems now, too. Any help is much appreciated.

 

I've gone over these posts:

http://www.totalchoicehosting.com/forums/i...showtopic=13520

http://www.totalchoicehosting.com/forums/i...installing+dada

http://mojo.skazat.com/installation/

 

and come up with a server error 500 on a nice dada mail/welcome to dada mail screen.

 

As with Thomas I did the config.pm thing, I uploaded DADA and mail.cgi into dada (which in turn is in the cgi-bin directory) (which in turn is in the public_html dir). I set the permissions as I believe they stated they should be.

 

Also, I checked case-sensitivities and found everything to be as they should. I also renamed dada_files to dadafiles after Stephanie's problems.

 

I'm using version 2.10.7. Any other help/suggestions would be most appreciated. Thx! -KD

Link to comment
Share on other sites

Ok. Forget it. I fixed it - it was the ASCII thing. I also just assumed that SmartFTP would default correctly.

 

So, in summation, the way to fix any computing problem, is to go nuts for hours trying to fix something, then post on a message board, then several minutes later figure it out by method of epiphany, or at least do something that was already suggested.

 

:goof:

Link to comment
Share on other sites

Ah, thanks for the welcome!

 

Umm, so I've run into the next problem as is the course of things like this. Maybe it's because I'm distracting myself with Aqua Teen Hunger Force in the background. I'm not willing to fix that, however.

 

So, here's the next situation:

I set up a list. When asked to type in a password or create a new list it goes to a server error 500. The Error FAQ suggests chmodding "dadafiles" to 777. It does not fix the problem, however. I'm not going through the advanced setup so I haven't altered any other files.

 

Any help is again appreciated. :goof:

Link to comment
Share on other sites

nope, that wasn't it. Hmm...

 

well, maybe - I might have done parts of it one way and other parts the binary way. I'll try to redo the whole thing again, but I"m going to have to take a break for a while.

 

Thanks for the help!

Edited by kmdini
Link to comment
Share on other sites

Ok. A step away from the comp and a complete reinstall with special attention to the ASCII stuff, the dadafile with no underscore, and all permissions worked.

 

Likely, it was as you say - that the ASCII installations were not consistent throughout. I hadn't even heard of binary vs ascii ftp stuff until today.

 

Thanks for the help! :)

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...