Jump to content

Gallery/imagemagick Problems


Recommended Posts

I just upgraded my gallery installation to 1.4.4-pl4, and can no longer upload images. Here are the relevant details:

 

1. Gallery's Configuration Wizard reports:

"Missing optional binary composite. Without composite gallery will not be able to watermark images, except you use NetPBM and have the pnmcomp binary installed. 2 of 3 ImageMagick binaries located." - seems like this is ok

 

2. Gallery's ImageMagick diagnostic wizard reports:

"Your ImageMagick directory (/usr/local/bin) is not in your open_basedir list

/home/exampleusr/:/usr/lib/php:/usr/local/lib/php:/usr/local/sqmail/:/tmp

The open_basedir list is specified in php.ini.

The result is, that we can't perform all of our basic checks on the files to make sure that they exist and they're executable." - I have no idea what this means...seems bad

 

3. The final confirmation for Gallery's Configuration Wizard reports:

"Note: Your server has the PHP open_basedir restriction set, and certain of your paths are not in the list of restricted paths (/home/exampleusr/:/usr/lib/php:/usr/local/lib/php:/usr/local/sqmail/:/tmp) This doesn't mean that they won't work, however it does mean that we can't verify that the paths are correct. If you are unable to upload photos correctly, please refer to the FAQ and to the diagnostics to resolve your problems." - same as #2, but different description

 

4. The FAQ entry listed in #3

http://gallery.menalto.com/modules.php?op=...install.faq.c.2

 

5. I followed their advice, and tried running Gallery in debug mode, uploading a single picture. I tried a couple of different pictures, and received the same pile of messages each time:

+ Lots of "convert: no decode delegate for this image format" messages

+ "sh: line 1: html2ps: command not found"

+ "convert: Delegate failed `"html2ps" -U -o "%o" "%i"'."

+ Three of "convert: Not a JPEG file: starts with 0x24 0x49."

+ "convert: Not a JPEG file: starts with 0x32 0x30."

+ Ending with "Error: Unable to make thumbnail (0)"

 

Much of this is over my head. I have had good luck with Gallery up until now. Any help would be much appreciated.

 

Best,

David

Link to post
Share on other sites

I cross-listed this issue at the Gallery forums. Here is what they had to say:

 

http://gallery.menalto.com/modules.php?op=...order=0&thold=0

 

"It has come to our attention that the ImageMagick development team recently modified the commandline parameter requirements for their most recent versions. This causes ImageMagick 6.1.0+ to be incompatible with Gallery 1.x in some circumstances.

 

If you see errors, while using ImageMagick, that are similar to those described in this bug on SourceForge, then you will need to downgrade your version of ImageMagick to something below 6.1.0.

 

This error will be resolved in the upcoming 1.5 release of Gallery, and if absolutely necessary, we will release a fix for 1.4.4. There are no plans for a 1.4.4 fix at this time."

Link to post
Share on other sites
  • 2 weeks later...

Hello, I'm new to the forums. I've been following this topic and others like it for a week now and still can't solve the problem. I'm having the same problem as David, and upgraded to Gallery 1.4.4.-pl5 and still having a problem getting my images to upload. I just want to check to see if others are getting the same warnings I am on the Gallery Configuration Wizard (Step 1):

 

---------------------

Warning

 

 

Missing optional binary pnmcomp. Without pnmcomp gallery will not be able to watermark images, except you use ImageMagick and have the composite binary installed.

 

 

12 of 13 NetPBM binaries located.

 

---------------------

Warning

 

 

Missing optional binary composite. Without composite gallery will not be able to watermark images, except you use NetPBM and have the pnmcomp binary installed.

 

 

2 of 3 ImageMagick binaries located.

---------------------

Warning

 

 

I can't find jhead. If it's installed and not in the path of the webserver user that's OK—you can specify the path by hand on the following page. If it's not installed, you can install it yourself. Jhead is a public domain EXIF parser. Source, linux binaries, and windows binaries can be found at the jhead homepage.

 

 

Can't find jhead

---------------------

Warning

 

 

I can't find jpegtran. If it's installed and not in the path of the webserver user that's OK—you can specify the path by hand on the following page. If it's not installed, you can install it yourself. Jpegtran is a free tool distributed by the Independent JPEG Group as part of libjpeg. Source may be found at the IJG homepage. Binaries may be found at the JPEG Club website or in the libjpeg package of Linux distributions.

 

 

Can't find jpegtran!

---------------------

 

 

Then it says, "Your installation passed with flying colors! Go go go!"

 

I select ImageMagick and I point it's path to "/usr/local/bin". I searched the forums and everyone says it's the correct path.

 

Then I go into Gallery Diagnostics: Check ImageMagick, and I get the same message David gets above:

 

 

---------------------

Note: Your ImageMagick directory (/usr/local/bin) is not in your open_basedir list

 

/home/movemen:/usr/lib/php:/usr/local/lib/php:/tmp

 

The open_basedir list is specified in php.ini.

The result is, that we can't perform all of our basic checks on the files to make sure that they exist and they're executable.

 

If it mentions open_basedir then it's because your system is configured with open_basedir enabled. You should talk to your system administrator about this, or see the Gallery Help Page.

 

 

---------------------

That's where I am right now. I've checked the Help Page and a lot of it's too deep for me to comprehend. Wondering if others have similiar problems and how they were ultimately solved.

 

steve

Link to post
Share on other sites
Hi spoon and welcome to the forums.

 

Please open a help desk ticket (link at top of page) and give them the same detailed information you just posted here and I'm sure they can help get it sorted out.

 

Thanks Bruce for the welcome.

 

So I've openned to and received a response to my ticket regarding this issue. By the way, I've managed to resolve most of the warnings by finding and installing the scripts that were asked for, so there's no problem there. I still can't get my images and thumbs to show up when I upload an image. The response to my Help Ticket said:

 

PHP has been recently upgraded to the latest stable version in the server and some PHP functions are not working as before in this version. It looks like the PHP group has deprecated these functions to close some security holes. This has affected a lot of scripts and updated versions of these scripts are available from the vendors. Your issue looks to be related to a function they use to find a binary.

ImageMagick binaries are present under /usr/local/bin/ directory. You can safely ignore this warning and install the software. Please get back to me with the example links if you experience any issues after the installation. Alternatively, you can search for an updated version of the gallery software.

 

So my ImageMagick path is correct, and I'm using Gallery 1.4.4-pl5 (lasted version). I also came across this discussion which coincides with the response I received:

http://www.totalchoicehosting.com/forums/i...showtopic=13717

 

Do I have any other options but to wait until Gallery's next build and hope they account for it? Has anyone gotten 1.4.4-pl5 to work on tch?

 

-steve

Link to post
Share on other sites

Spoon,

 

A couple weeks ago I installed 1.4.4-pl4, when I read this post, I went and downloaded the newest version, 1.4.4-pl5 and just finished installing it and it appears to work fine.

 

On the first page of the configuration wizard, I ignored all the warnings and just continued. I selected ImageMagick and used this path: /usr/local/bin (I just checked my config.php and confirmed, there isn't a trailing slash).

 

Hope that helps!

Link to post
Share on other sites

Thanks everybody... I've solved it. It didn't have anything to do with PHP or security or permissions at all.

 

My 'Albums URL' wasn't correct, even though my 'Albums Directory' was. My bad - sorry for all the drama.

 

-steve

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...