Jump to content

sdempsey

Members
  • Content Count

    18
  • Joined

  • Last visited

Community Reputation

0 Neutral

About sdempsey

  • Rank
    New To The Neighborhood
  1. I followed the instructions to the letter and uploaded the files again (all in ASCII mode except the images). I'm still stuck with the same error. This is very confusing indeed. http://www.gaisan.com/cgi-bin/mt-check.cgi says that everything is fine. Same as the post you referred me to. I've even tried using a different FTP client and unzipping the files again. I've looked at this error on the official 6apart site at http://www.sixapart.com/movabletype/kb/err...ported_dri.html My mt-check.cgi says that DBD:mysql is installed and so is the DBI Perl module. I'm stumped.
  2. Hi guys & gals, Just tried to update to Movable Type 3.3. Everything seemed to be going OK until I got the following ominous message>> Got an error: Unsupported driver MT::ObjectDriver::DBI::mysql: Global symbol "$pfx" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 390. Global symbol "$tbl" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 390. Global symbol "$tbl" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 390. Global symbol "$driver" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 391. Global symbol "$driver" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 394. Global symbol "$id" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 395. Global symbol "$driver" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 396. Global symbol "$driver" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 398. Global symbol "$class" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 398. Global symbol "$obj" requires explicit package name at lib/MT/ObjectDriver/DBI.pm line 398. Unmatched right curly bracket at lib/MT/ObjectDriver/DBI.pm line 400, at end of line lib/MT/ObjectDriver/DBI.pm has too many errors. Compilation failed in require at lib/MT/ObjectDriver/DBI/mysql.pm line 9. BEGIN failed--compilation aborted at lib/MT/ObjectDriver/DBI/mysql.pm line 9. Compilation failed in require at (eval 7) line 1. BEGIN failed--compilation aborted at (eval 7) line 1. Mt-check.cgi says mysql is present. I've done a bit of searching on other forums and it may be something to do with the server configuration. A few posts in 6apart's own forum said that there's a known issue with a cpanel update which screws up perl modules. Does anybody have any ideas how to remedy this as I've wasted around an hour and gotten nowhere.
  3. I use WSFTP also. Get it from www.ipswitch.com. It may not be free but it performs extremely well and can do nifty things like recursive file permissions updates which save a lot of time. Get the evaluation version first & see what you think
  4. I understand about the SYN ACK cycle. SOmetimes I can FTP data to/from the server perfectly well (I'm not using passive mode) and other times I can't, which is genuinely confusing. It could be that when network traffic is high and the roundtrip time is uneven, the syn-ack cycle looks irregular to the Panda intrusion detection software. This could explain why panda thinks the total choice server is initiating a port scan but it could also be that totalchoice have proxy servers which are confusing my intrusion detection software by sending acks back from a different IP. I was wondering whether your servers do port scan clients that appear to behave irregularly. Also, we're experiencing very sluggish FTP performance from this server over the past few days which is increasing the problem.
  5. Hi guys, I've noticed this happening a few times and I'm not sure what to make of it. My firewall (Panda Titanium using TruPrevent heuristics) sometimes reports port scans during an FTP session with server90.totalchoicehosting.com. The firewall reports the scan, blocks it and then the connection with the FTP server goes dead. It's a bit confusing. Any ideas ?
  6. If you prefer to work visually using a DB administration GUI then you can always use MySql front. http://www.mysqlfront.de MySQL really is a great database. One of the fastest with a good overall level of standards compliance (ANSI-SQL). Hope this helps.
  7. sdempsey

    Notepad

    Windows automatically restores notepad if you copy over it or delete it. This is a sensible security feature. One possibility is - Change Explorer view options to show system files - Open folder C:\WINDOWS\ServicePackFiles\i386 - delete notepad.exe - Open folder C:\WINDOWS\system32\dllcache - delete your notepad.exe - Open folder C:\WINDOWS\system32 - delete your notepad.exe - Open folder C:\WINDOWS - delete your notepad.exe Now you'll need to stop the file being copies again by excluding it from the restore\filelist.xml. ---------------------------- attrib -s -h -r %windir%\system32\restore\filelist.xml ' edit the file notepad.exe %windir%\system32\restore\filelist.xml ' now add the following lines to the excludes node of filelist.xml <REC>%windir%\system32\notepad.exe</REC> <REC>%windir%\notepad.exe</REC> ' change the attributes back to hidden and read only. attrib +r +h %windir%\system32\restore\filelist.xml That should work if you absolutely MUST delete it.
  8. There are a few sourceforge projects. Try http://guiguy.wminds.com/downloads/pdf2htmlgui/ & http://pdftohtml.sourceforge.net/. Hope you're having a good christmas.
  9. This may sound like a very strange suggestion but try checking his computer's clock. Gmail, norton and many banking sites timestamp customer access for security & licensing reasons and if a computer's clock is out of synch it doesn't work. I saw a similiar problem with gmail a while back. Here's a link I found at the time which pointed me in the right direction. http://www.gmailforums.com/lofiversion/index.php/t12011.html Interestingly enough, Windows loses some time in every other mode except safe mode where it seems to synch better with the CMOS clock. Probably has something to do with windows internal code thread priorities. That's just a guess though, I used to write Windows services for a living. Anyway sometimes malware or just badly written applications interfere with the clock, mess up timestamps and time-based security tests. I hope this helps.
  10. The mail delivery failure messages you describe often come from a Mail Transfer Agent (MTA) on your own network and effectively mean that your MTA couldn't transfer the message to the remote host corresponding to the Mail eXchange (MX) record for the domain you're sending to OR that the email address specified is unknown to that remote host. depending on the configuration of your virus checker AND the placement of your MTA, these emails won't be treated as incoming mail as they're originating at your own server, within your own network and are correctly bypassing your main analysis tool. I hope I've understood your questions correctly but this seems intuitively correct.
  11. Hi guys, we fixed the problem. For whatever reason our config.php file had become corrupted with a hidden character around the database name. I can only conclude that when we were fixing another install problem we introduced this one. When we re-editted the file on a unix system and cleaned it up and copied it back it all worked properly. A quick look through the sugar source told us that even though magic_quotes was switched on , sugar couldn't exactly match the db type and hence, didn't clean up the apostrophes. Problem solved. Thanks to everybody in Totalchoice who helped us with this problem. We value your committment to providing us with a comprehensive and reliable hosting service. regards, ...shane // Managing Director // Gaisan Technologies // www.gaisan.com
  12. Hi David, I've done this step already and I can assure you that whether the magic_quotes is reported as on or off it makes no difference. The confusing thing is that magic quotes isn't doing what it's supposed to here and I can't find anything on the sugar lists describing this as a known sugarcrm problem. Like I said, very confusing. The best I've been topld is that sometimes "individual server configurations have bugs that prevent sugar from working as expected" by another developer on the sugar boards. This smacks too much of the black arts and I'd rather a more concrete answer to the problem. regards, ...shane
  13. Hi David, OK, here's the trace from the database. As you can see it's just not getting escaped despite the fact that magic_quotes_gpc is switched on. I've tried switching it off in the .htaccess in the hope that the SugarCRM code will compensate but that's not working either. I just get the same error. When I turrn magic_quotes_runtime on then the page HTML gets escaped so nothing works. e.g. instead of an image you see However, my colleague has setup a similiar deployment on totalchoice server90 without using SSL and it's working fine. I'm a bit mystified with all this. regards, ....shane
  14. Hi, We're trying to run our own sugarcrm 3.5 installation on server90. We've run sugar on a range of boxes before, linux and windows, and never had any problems with it. However we can't seem to get magic_quotes_gpc to work properly on our totalchoice server. Even though it's on by default (according to phpInfo.php) and was switched on in the .htaccess file it's just not working, database updates are still failing when there's an apostrophe in a field. I'm pretty much fed up of this and I'd appreciate any advice or help... regards, ...shane
×
×
  • Create New...