Jump to content

I Give! Google's Got Me Whooped!


Recommended Posts

I give up trying to figure out Google. Just when I think I have everything figured out between posts on the 'net, info from Google, info from Scott, something happens that convinces me that I know nothing about Google!

 

I have a client that's a fishing charter boat captain and built a site for him. I've tried to optimize it from start to now and I've gotten OK results for a pretty competitive field.

 

He has a 1969 GTO (car for those unfamiliar) that he loves. He wanted to put some pictures on the web and let folks see his baby. Well, I noticed that a little over half of our search-engine visitors came looking for the car. That doesn't help determine if the fishing site is working so I split the car into its own subdomain to keep my stats pure.

 

Tonight I just looked for the fun of it to see how it ranks for "1969 GTO" and it was at the bottom of a page -- page 1! This doggone mostly unoptimized (has a desc but no keywords), trivial content (3 small paragraphs), show-off-my-car site with 8 pics and links back to the fishing site, PageRank of ZERO, nothing page is page 1 in searching! And that's out of 53,600 results Google returned on that phrase!

 

I give up! :dance:

Link to post
Share on other sites

:dance: :lol:

 

You made me laugh Jim... thank you.

 

Maybe you are better then you think! :D

 

 

Don't look at any rankings right now... they are not real. Wait a couple days and maybe it won't be so high and you won't be so discouraged... boy if that does not sound funny (worse results for encouragement!).

 

P.S. Your images are not showing up on the goat (car for those unfamiliar) page.

Link to post
Share on other sites

Ah, that's better - I'm down to position #10 now. Much better than #1! :lol:

 

Thanks for the note about the pics - they are part of the template from the main site so the links need and extra "/" or something. I'll fix it when I get home.

Link to post
Share on other sites
Ah, that's better - I'm down to position #10 now. Much better than #1! :lol:

That's because I added "1969 GTO" to all the pages on all of my sites ;)

 

When I was in college my brother and I had a 56 chevy coupe, two tone green and white factory paint, wide white walls with the little stock hub caps, looked like a stock 6 cylinder even had a little exhaust pipe sticking out under the rear bumper.

 

389 HO tri-power under the hood, Headmann headers, and an Olds Hydramatic with a B&M shift kit Thumbs Up

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...