Jump to content

Permalinks, Seo, My Site Is Broken, Oh My!


Recommended Posts

Hi,

 

I have a blog that I've maintained for seven years now. I have the default Wordpress permalink structure (EXAMPLE: http://www.lauralohr.com/?p=123) and I want to change it to include the post name, (Like this: http://www.lauralohr.com/sample-post/).

 

My first question is, for SEO, what permalink structure should I choose? I know I want post name included, but should I also include post id? date? I want to change from the default so I can take advantage of the SEO from the links. (So, like this: /%postid/%postname%/)

 

Secondly, I have installed the Redirection plugin to handle the 404's resulting from changing the permalink. When I activate the plugin, VOILA! I have beautiful links to my posts----

 

EXCEPT on my home page. I have a 404 error on my homepage, on the first post.

 

My blog lives in a folder on my root called WordPress. My home page is http://www.lauralohr.com/wordpress, however, my links come up http://www.lauralohr.com/name-of-the-post.

 

I'm not sure what needs to be done to make my home page not 404.

 

In settings, in the dashboard, my WordPress Address (URL)is http://www.lauralohr.com/wordpress. My Site Address (URL)is http://www.lauralohr.com.

 

Any help would be much appreciated!

Link to post
Share on other sites

There are so many options and reason to use each option for permalinks that I am hesitant to really suggest one, as it really depends on your needs and desires. However, I recommend reading this excellent article on permalinks, which touches on SEO as well as some caveats that affect things like getting listed in Google News.

http://docs.appthemes.com/tutorials/wordpress-permalink-structure/

 

Concerning that plugin, unless you have changed your domain name or your install path/directory, then I highly recommended that you don't use it. The WordPress permalinks settings and mod_rewrite rules in your .htaccess will take care of everything, That is WordPress will automatically do the work of changing/redirecting http://www.lauralohr.com/?p=123 to http://www.lauralohr.com/sample-post , if some one follows the old style URL. You can see this in action on the WordPress news blog at http://wordpress.org/news/?p=30

 

.

Link to post
Share on other sites

That article was fabulous! Thank you for sharing that! It helped me decide what structure to go with.

 

So, the plugin is deactivated. I went into settings and selected my desired permalink setting, but now when I click on the links, they never load. Also, I am still getting the 404 error on the homepage. I did not see anything to copy from the permalinks page to my .htaccess file when I updated the structure.

 

It seems like I'm missing something.

Link to post
Share on other sites

There could be an issue with how you have you redirects setup so that your install loads from /public_html/wordpress(which is your install path) versus just /public_html. If /public_htm/wordpress is were you originally installed your WordPress, then you having changed your install path.

Check out what you have set for WordPress Address (URL) and Site Address (URL) in your wp-admin under General options.

 

As for the .htaccess entries, they should have been added by WordPress, with no interaction from you. If they can not be added by WordPress, you would have received a notice on the permalinks screen.

 

If you cant find the root cause, please open a ticket with your WordPress admin information and I will gladly review the setup for you.

Link to post
Share on other sites

Thanks, Dick. That verifies some of my suspicions!

 

Yes, I do have my wordpress installed in /public_html/wordpress and not the root /public_html/

 

My admin settings are as follows:

 

WordPress Address (URL) http://www.lauralohr.com'>http://www.lauralohr.com/wordpress'>http://www.lauralohr.com/wordpress

Site Address (URL) http://www.lauralohr.com

 

I've tried to make changes in the admin settings had to contact support last night to roll back some of my files. I really did a number on them.

 

Are my settings correct? What should I do to remedy this? I've always preferred that my home page/site url be http://www.lauralohr.com and drop the subdomain from the url. At the same time, I don't want the blog in my root either.

 

Suggestions? Ideas? I know there is an easy fix to this, I just can't put my finger on it! :)

Link to post
Share on other sites

OKAY, so I had a BIG, HUGE success, with the past few comments you've left here. YEA!

 

So, I changed the general settings in the dashboard from this:

 

WordPress Address (URL) http://www.lauralohr.com/wordpress

Site Address (URL) http://www.lauralohr.com

 

to this:

 

WordPress Address (URL) http://www.lauralohr.com/wordpress

Site Address (URL) http://www.lauralohr.com/wordpress

 

My home page has no 404 error. All my links seem to be working. AWESOME.

 

Now, if I could drop the subdomain from the home page and the links. For example, I want to go from this:

 

http://www.lauralohr.com/wordpress/3008/blogher-2012-my-thoughts-and-critiques/

 

to this:

 

http://www.lauralohr.com/3008/blogher-2012-my-thoughts-and-critiques/

Link to post
Share on other sites

http://www.lauralohr.com/3008/blogher-2012-my-thoughts-and-critiques/ should be working now but it will take some databases changes to correct the old links. I have some MySQL queries that I can run shortly to make those changes.

 

Also, you can now change your URL settings back to what they were to support the new setup.

Which was:

WordPress Address (URL) http://www.lauralohr.com/wordpress

Site Address (URL) http://www.lauralohr.com

 

These settings translate to WordPress Address (URL) = Install path and Site Address (URL) = URL you want to display.

 

 

To get to this point I removed all the redirects in your main htaccess and deleted the /wordpress htaccess.

I then added the WordPress rewrite rules to your main htaccess.

Finally I edited the main index.php in public_html to be require('./wordpress/wp-blog-header.php');

Link to post
Share on other sites

Thank you so much for all of that!

 

I reset the general setting to:

 

WordPress Address (URL) http://www.lauralohr.com/wordpress

Site Address (URL) http://www.lauralohr.com

 

Links are working, but my main page is still redirecting to http://www.lauralohr.com/wordpress,'>http://www.lauralohr.com/wordpress, even if I specifically type http://www.lauralohr.com as the url address. I'm still getting a 404 on the main/home page, as a result. :blink:

Link to post
Share on other sites

OK, updated the .htaccess rules as they saved again from the first URL change. It's always something simple that you overlook. Clear your browser cache out or just close and restart it, then poke around. Except for some database entries that need to be cleaned up, reviewing that now, I think it is working as you want.

Link to post
Share on other sites

You are welcome and glad I could help, sometimes WordPress just needs a swift kick to get it to do what you want. As for that last error, it should be fixable and I will poke it at in a bit.

 

One other thing though, I did see a couple of issues with your Reviews pages and/or links. They appear to be related to the Thesis plugin, you probably just need to check that any links you set up there now match the new URL.

Link to post
Share on other sites

Ahh, yes, the Reviews page. I thought it looked a bit tweaked. I've had problems setting that up when I've made changes in the past. I'll have to fumble through that and redefine the call to that category. I'm certain that will fix it.

 

Also, I did notice some of my media (photo/videos) that I uploaded through the WP uploader are missing. I assume that will be resolved with the databases?

Link to post
Share on other sites

Now, only getting the 404 if I go directly to http://www.lauralohr.com/wordpress, but I'd rather that happen than have the subdomain show up in the url.

 

I added a blank index.html to this directory as it will override index.php, so we don't cause any actual issues to WordPress. Then I created a redirect for the index.html file only, again so it doesn't affect WordPress. Now any one visiting http://www.lauralohr.com/wordpress directly, should end up on the main page.

 

I'm heading out for a while, but please check that out and let me know if you are still having issues.

Link to post
Share on other sites

Hi Dick,

 

Wow! That was awesome all that you did!

 

Here is one of the images that is missing:

 

http://www.lauralohr.com/wp-content/uploads/2012/08/image-300x232.png

 

When I try to view the image, I get a 404 error.

 

The image is located on this post:

 

http://www.lauralohr.com/3016/the-cats-meow-or-roar-ringling-bros-barnum-and-bailey-circus-with-alexander-lacey/

 

On that particular post, the images that I linked to from Flickr are showing up, but that image and this image that I uploaded through the WP uploader are not showing up: http://www.lauralohr.com/wp-content/uploads/2012/08/ringling-dragons.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...