Jump to content

Vcard Download From Site


genericuser3
 Share

Recommended Posts

Hi! A client wants me to add a link on their site so visitors can download their VCards.

 

She sent me the files, I uploaded the .vcf files, created the link on the page, uploaded the page -- but when the link is clicked a new page opens with the Vcard information. This isn't supposed to happen - I should get a dialog box asking me what I want to do with the *.vcf file.

 

When I test the page locally the file works as expected. But when it's on the TCH server it does not work --

 

Any suggestions? Ideas?

 

Thanks.

Link to comment
Share on other sites

Welcome to the forums genericuser3 :)

 

According to this all you should need to do is create a hyperlink to the .vcf file. If the card is opening instead of you being asked for it to be downloaded then what ever you are using to view the link has been set as the default application to open the file.

Link to comment
Share on other sites

Here is something for you to try. Add %20 for the space character between the first and last name of the file name.

 

Change:

><a href="Andrea Wandersee.vcf">Download V-Card</a>

 

To:

><a href="Andrea%20Wandersee.vcf">Download V-Card</a>

 

Thanks, yes I removed the space and tired adding 20%, still no joy. Originally the client emailed me the files, I thought possibly the files were corrupt so I just created a vcard from my address book, uploaded it and still I get window not a dialog box.

 

Are you guys sure that it's not an issue with the server?

Link to comment
Share on other sites

Ok I just tested the page on another server - not TCH and everything works exactly as it should:

 

Andrea and Test have files attached the others don't--

...............

 

So it's possibly a problem on your server?? I was going to move this client to TCH - but I can't if this Vcard will not work.

 

Can someone look into this a bit more?

Edited by genericuser3
Link to comment
Share on other sites

I don't see how it can be a server related issue when I test with IE it prompts to download.

 

If you would like someone to look into it further you will have to open a ticket with the help desk. You can find a link at the top of this page or in my signature.

Link to comment
Share on other sites

I don't see how it can be a server related issue when I test with IE it prompts to download.

 

If you would like someone to look into it further you will have to open a ticket with the help desk. You can find a link at the top of this page or in my signature.

 

 

Do both links work for you? The second one works form me and that is not on your server. So do both work or just the second one?

Link to comment
Share on other sites

The server sees the vcard as a text file therefore when FF checks the MIME Type it also sees it as a text file. This is corrected by adding a custom MIME Type via your cPanel under Advanced Option > MIME Types. The custom MIME type should be created with the settings MIME Type: text/x-vcard and Extension: vcf .

 

However, I have already added this MIME type for you, just clear your cache in FF and try again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...