Jump to content

Send Referrers, for this feature to work


darkgraysheep
 Share

Recommended Posts

I've set up a subdomain on my account for a friend of mine for his blog. I installed WP through fantastico and tested the logon on my own machine. Everything worked fine. But when he tried to change things in his options panel he got the message:

Sorry, you need to enable sending referrers for this feature to work.

 

After doing some research I found an article from WP about how to fix the problem. I had him try the IE fix and the Zone Alarm fix. Neither of those worked. So then I tried the changing the subdomain url fix. That one worked for him to change the options of his blog, but then he tried to post an entry and he got the error message again! Argh.

 

Has anyone else had this problem? How do I fix it?

Link to comment
Share on other sites

I have installed Wordpress many times and have never encountered this error. It sounds like a PC side problem other than a WP problem.

 

I would try disabling Zone Alarm and trying it.

 

Was the subdomain created before the install of WP? What URL are you using to access the Admin panel? Have you tried using?

>http://yourdomain.ext/subdomain/wp-admin/admin.php

Did it work?

Link to comment
Share on other sites

I haven't experienced this problem before... other people seem to be able to backtrack to my blog from their stat counter.

 

Like Bruce said, try shutting down Zone Alarm (or other firewall/privacy software that you might have) - they may be blocking referrer to enhance your "privacy".

Link to comment
Share on other sites

I have installed Wordpress many times and have never encountered this error. It sounds like a PC side problem other than a WP problem.

 

I would try disabling Zone Alarm and trying it.

 

Was the subdomain created before the install of WP? What URL are you using to access the Admin panel? Have you tried using?

>http://yourdomain.ext/subdomain/admin/login.php

Did it work?

 

 

 

I've installed WP several times on my on computer, both manually and with Fantastico, and have never had this problem either. But apparently it is common since there were a lot of replies on the WP thread about the fix for it. It seems that it is a 2.0 problem. I did have my friend disable Zone Alarm and while it works when he does that, I was hoping to find a fix that didn't put him at risk.

 

The subdomain was created before the install of WP.

And yeah, the URL used to login is the one like that up above except that it says wp-login instead of login. As I said he can login just fine, it's just when he tries to post that he gets the "referrers" message.

 

Thanks for your help!

Link to comment
Share on other sites

I don't use Zone Alarm but that seems to be the root cause of the problem. He will have to create a rule that passes the referrers when using the subdomain links. Sorry don't know how to make that happen. Maybe one of our Zone Alarm users can help with that.

Link to comment
Share on other sites

I don't use Zone Alarm but that seems to be the root cause of the problem. He will have to create a rule that passes the referrers when using the subdomain links. Sorry don't know how to make that happen. Maybe one of our Zone Alarm users can help with that.

 

 

THe WP page I linked actually had a zone alarm fix but it didn't work either, that is why I came here. Hoping someone else had the problem and had been able to fix it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...