Jump to content

Domain To Propogate After Site Is Setup


mycat2
 Share

Recommended Posts

I have a new client and we are using wordpress for their website. The client will NOT change the DNS until the site is ready to be launched.

 

Wordpress has been installed via fantastico in the main directory of the server.

 

I chatted with your online support earlier because when I try to login -- using the temporary login: server name/~username/wp-admin -- to access the wordpress admin I get redirected to the parked page where the site is current registered - understandable since the DNS has not been changed.

 

Support said I should change the PHP to the temporary URL in I believe 2 different places however I can't figure out which files need to be changed - I don't think it's the config file or is it?

 

So my question is specifically what PHP files need to be changed, what line for code needs to be changed and how should it be changed so I can access wordpress BEFORE propagation?

 

Thank you!

Link to comment
Share on other sites

You should be able to get into the admin panel using h*tp://your-server-IP/~username/wp-admin then go to the settings page and enter h*tp://your-server-IP/~username in both fields. Remember to change it once propagation takes effect.

 

Replace the h*tp with http. Replace your-server-IP with the IP address in the welcome email. And replace username with the actual user name.

Link to comment
Share on other sites

Accessing via: h*tp://your-server-IP/~username/wp-admin should work but it does not. I tried that.

 

I get redirected to h*tp://www.mydomian.com/wp-login.php?redirect_to=http%3A%2F%2F208......blahblahblah.

 

For some reason it redirects to the parked domain not the temporary URL.

 

 

 

I'm going to uninstall wordpress - it may have been a problem with the installation - the kubric template is not being used so something may have gone wrong with the install. (??)

Edited by mycat2
Link to comment
Share on other sites

I just found another way to do it without modifying the settings.

 

In the wp-config.php file add the following two lines.

 

>define(‘WP_SITEURL’, ‘http://your-server-IP/~username’);
define(‘WP_HOME’, ‘http://your-server-IP/~username’);

 

Just remember to remove them once the site propagates.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...