Jump to content
Sign in to follow this  
puretext

Www Doesn't Work For Gallery 2?

Recommended Posts

I'm in the process of re-installing Gallery 2. I've just finished uploading a mass of pictures and I'm discovering something weird: If the address given is neumatikos.net/gallery2, I can see my pictures. If the address is www.neumatikos.net/gallery2, everything works - but no pictures. What's up with that?

Edited by puretext

Share this post


Link to post
Share on other sites

I can´t see them with either www or not.

 

Are you using the hotlink protection feature in cpanel?

Share this post


Link to post
Share on other sites

"HotLink protection is currently disabled."

 

It does have a tendency to redirect to www. I had assumed that was something going on with my ISP, since I'd never noticed it before. I have to go to the address, take out the www, and then reload.

Share this post


Link to post
Share on other sites

Ok.

 

Please submit a ticket and ask the techs to have a look at this.

 

Please let us know how it goes. :)

Share this post


Link to post
Share on other sites

I believe I've fixed it.

 

It wasn't a hosting problem at all; it was a problem with the URL Rewrite module for Gallery2. Gallery 2 only accepts requests from whatever domain it's installed in. Alternate subdomains calling for the same pictures are considered hotlinking. Since www is technically a subdomain, it was "protecting" me from hotlinking by disallowing any of the pictures.

 

I turned off two settings to fix it:

  • Block hotlinked items
  • Send HTML for hotlinked items

 

With these two settings turned off, everything worked fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×