Jump to content

Wp 2.2 - Dashboard "body" Missing


dirtvoyles
 Share

Recommended Posts

Time for my latest error issue. I jumped right in and upgraded to 2.2 (I know, with great new software comes great new bugs). I followed the upgrade instructions, backed up, and kept the files like the instructions said. So far, all plugins seem to be working and all functionality is there.

 

I do have 2 issues (probably related): The main body section under "Dashboard" is blank. There aren't the usual links to "Write a post", etc. The functionality is there if I go to "Write", but the body is missing.

 

Also, after "Incoming Links" and "Comments" in the box to the right, I get this error: Fatal error: Call to undefined function: get_private_posts_cap_sql() in /home/*******/public_html/blog/wp-admin/index.php on line 64

 

If you guys can point me in the right direction, I'm more than willing to listen. Google and WP-forums aren't helpful yet, and you guys usually are helpful. I'll keep looking, but I'm betting y'all will get me before I find it myself. :P

Link to comment
Share on other sites

Sorry Dan, haven't upgraded yet. I usually wait a few days before I do. Sounds like not all the files overwrote properly possibly.

 

Did you delete any files before uploading the new version? I always remove the files first and then upload the new ones. I do not overwrite.

Link to comment
Share on other sites

Yeah, I deleted everything like the instructions said, and kept wp-config, index.php, etc. like WP said to do.

 

I mean, this isn't an emergency since it is working fine, I just miss my Dashboard page. I could live without it, but would rather have it working properly. Perhaps I should have overwritten something and I didn't.

 

I'll keep trudging along and googling until something comes up. If you hear something, let me know.

Link to comment
Share on other sites

I agree that sounds like a missing or incomplete file. get_private_posts_cap_sql() is part of wp-includes/post.php and is new to 2.2.

 

 

So, try re-uploading wp-includes you think? I've got a complete backup of the /blog, so I'm not scared about screwing up too much.

Link to comment
Share on other sites

*tear* I love you guys.

 

Simple solutions, fast help, friendly faces (except Bruce :P )

 

We need to have a TCH party so I can buy you guys a pop, or something.

Edited by dirtvoyles
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...