Jump to content

Nice Looking Urls


Recommended Posts




At first I wanted to go for Movable Type, but since installing the script did not work at all for me (have read installation guide at movable type website + here at total choice hosting) , I have decided to go for Wordpress since I do how to work with php, compared with MTs cgi/perl.


Also i had a problem with my host, so am kinda MT-bored, although I think the system is great, but then again Wordpress is free!


One of the reasons I wanted MT is because of its nice looking urls (not index.php?message=123123) , but now I saw somebody was using Wordpress with nice looking urls :). This was timhodge's webpage called Garduque.net


now, does anybody now how I can get these nice looking url's as well? Does it have anything to do with mod_rewrite? perhaps you can post the code I have to use.


your help is appreciated! thanks!



Edited by Johnns
Link to comment
Share on other sites

Welcome to the forums John


Yes, WP will create the mod_rewrite commands for you. You can follow these steps below.


1. Open File Manager in cPanel and browse your blog folder.

2. Highlight the .htaccess file and change the permissions to 666

3. Go into your blog's Site Admin

4. Select Options and then Permalinks

5. Set up your structure for archive and category links to use

6. Click where is says Upate Pemalink Structure

7. Test view your site to be sure it is working the way you want

8. Go back to File Manager and change the permissions of the .htaccess file back to 644


If you don't want Wordpress to update your .htaccess file you can also copy/paste the mod_rewrite statements from Wordpress to your .htaccess file manually.


That's pretty much it.

Link to comment
Share on other sites

Hmm, very strange.


In my Permalinks setting I use this structure




And for archives I use




Which looks like what you chose.


Did you let Wordpress do the updating or did you use the copy/paste method?


When I did it, I used copy/paste. May want to try that. It could be that the update was not successful.

Link to comment
Share on other sites

I also used the copy/paste method.


the code doesnt work for me :s it cant seem to find the page :s


Not Found

The requested URL /category/uncategorized/ was not found on this server.


Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


any suggestions?

Edited by Johnns
Link to comment
Share on other sites

I fixed the problem by adding a prefix /index.php/


apparently mod_rewrite isnt installed on the server? :)


ive send a message using the ticket system of my webhost asking him to enable the mod_rewrite function, since i dont like the index.php/ prefix.


well, we'll see.


thanks for all your help!

Link to comment
Share on other sites

What Bruce told you is about it. Define the structure and hit the Update button. If WP can write to your .htaccess it will, if not it will tell you so and you will have to copy and paste. Are you saying you saw something like this, and you copied that into your .htaccess and uploaded it to your site?


Perhaps you can post the contents of your .htaccess and we can figure out where that /index.php/ is coming from. Cause that's weird.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...