Jump to content

Comment E-mail Notification


Recommended Posts

My site went down for some reason very briefly a few days ago. Shortly after that I realized that my Comment Notification E-mails were not working. I checked all my wordpress settings and the E-mail is still correctly listed, and the option to recieve a notification when someone comments is checked, but I'm still not getting an E-mail when someone comments.

 

Any suggestions?

Link to post
Share on other sites

Never seen this trouble before. As a troubleshooting step, you might try changing the email address and then trying again; that would tell you if the problem is with WP or with your email provider.

 

If you get the notification at the second email address, then you might check your filters and such to make sure the message wasn't getting tagged as SPAM by your email provider.

 

If you don't get the notificiation at either email address, then you might check with the WordPress support site.

 

That's what I would do for my next couple of steps, at least, if I were having this trouble (after, of course, checking with these fine TCH folks!).

 

Maybe somebody else will have a better suggestion.

Link to post
Share on other sites
  • 4 weeks later...

My WordPress also quit sending me email notification for comments around October 9th, even though I had not changed anything. I was running WP 1.5.1.3, and then upgraded to WP 1.5.2 on 10/17. But, the upgrade didn't fix it either.

 

I looked up the WP support forum, and found this thread at http://wordpress.org/support/topic/42963 , but I'm not sure if how to make that change, and whether if that change to the php email function would fix this.

 

www.djchuang.com

Link to post
Share on other sites

I run several wordpress blogs and have never had a problem with receiving comment notifications.

 

Under the Options General tab make sure you have a valid email address. Under the Options Discussion tab make sure the checkbox to be notified when anyone posts a comment is checked.

 

I run version 1.5.2 of Wordpress. Do you have any plugins installed that chould be preventing your comment emails?

Link to post
Share on other sites

Comment notification in my WP 1.5.2 started working again, magically. I have not changed any settings on my server nor in my WP options, and my email address (@gmail.com) did not have any change to its spam filter. Don't know why, but happy it's working now.

Link to post
Share on other sites
  • 2 weeks later...

I had this same problem. Was hit by comment spam, and was getting notices several days later for comments I'd already nuked.

 

I just installed Bad Behavior and Spam Karma 2, and life is good, but I was wondering why my emails were showing up late. Guess I was not the only one.

 

-kj-

Link to post
Share on other sites

Do you do this in place of requiring people to register in order to post comments? Because I require people to register to post comments on my blog, and then I have to approve the first comment from each user before they can be posted live on the blog.

 

However, I've often thought it would be good to allow anonymous posts, so maybe I'll try Spam Karma 2 and see how it works for me.

Edited by abinidi
Link to post
Share on other sites
If you are not using some sort of spam comment plugin on your blog you are just asking to be spammed. I recommend Spam Karma 2 to anyone running Wordpress.

 

Actually Wordpress' default spam countermeasures are pretty decent. I had good results with those and Kitten's Spaminator up until I tried Bad Behavior (awesome) and SK2 (also amazing). Those two are proving unbeatable.

 

-kj-

Edited by kjarrett
Link to post
Share on other sites

Paul, I use SK2 and the comments approve themselves and users can comment without registering. In fact I have registering turned off on my blog.

 

I have a couple of WP test blogs also set up where I test other plugins and I have SK2 on them as well. They collect a lot of spam and nothing has gotten through (so far). I don't expect any but you never know. These spammers get more creative in their tactics all the time.

Link to post
Share on other sites

Well, I've tried it.

 

I disabled the restriction on only allowing logged-in users to comment.

 

I installed Spam Karma 2, and bad-behavior.

 

We'll see if it works!! ;)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...