Jump to content
Sign in to follow this  
TCH-Thomas

Apple Iphone / Ipod Touch Multiple Vulnerabilities

Recommended Posts

From: Secunia

secunia.com/advisories/28497/

 

Rating: Highly critical

 

Description:

Two vulnerabilities and a security issue have been reported in Apple iPhone and iPod touch, which can be exploited by malicious people to conduct cross-site scripting attacks, bypass certain security restrictions, or to compromise a vulnerable device.

 

1) An unspecified error in the handling of URLs exists in Safari. This can be exploited to cause a memory corruption when a user is enticed to access a specially crafted URL.

 

Successful exploitation may allow execution of arbitrary code.

 

2) An error in the handling of emergency calls can be exploited to bypass the Passcode Lock feature and allows users with physical access to an iPhone to launch applications without the passcode.

 

This security issue is reported in iPhone v1.0 through v1.1.2 only.

 

3) An error in Safari can be exploited by malicious people to conduct cross-site scripting attacks.

 

Solution:

Update to version 1.1.3 (downloadable and installable via iTunes).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...