Jump to content

Email And Spam Assasin


Recommended Posts

Hi,

 

I am tired of all the spam I am getting. I have spambox enabled but what I wanted to do was set up a filter to delete all mail marked as spam by spam assasin. I don't care if I miss a valid email I just want to delete it all. In email filters there are the following instructions

 

"To filter all mail that SpamAssasin has marked as spam, just choose "SpamAssassin Spam Header", "begins with", and then enter "Yes" in the box. " I set up this filter and set "Discard" as the destination but nothing is being deleted - it is still sitting in the Spambox. Am I missing something here?

 

Also, my email is set up to deliver anything *@mydomain. I've looked at the instructions but I stil haven't figured out the best way to set it up for a specific address at my domain. There are two email aliases that are giving me the most trouble so I thought this might be another way to cut down on the spam problem. I hope I am explaining this ok -

 

I used to have my email on a website and removed it to late - I am getting hundreds of spam emails a day.

 

Thanks,

 

Kim

Link to comment
Share on other sites

Spam is a major problem. This is the solution that is working for me.

 

One of the forum members ScooterB posted how he set his up in this thread. I pretty much use his setup with a slight modification. I've copied his set up here.

 

Requirements:

1) Wanted Spam Assassin to watch over all my email accounts.

2) Wanted to move all those emails marked as spam to another email account for later retrieval and review.

3) Didn't want each email account to have their own Spam box.

 

In cPanel:

1) Created an email account "Spam@****"

2) Created a filter "SpamAssassin Spam Header", "begins with", and then enter "Yes" in the box. Destination "Spam@****".

3) Enable Spam Assassin.

4) Do not enable Spam Box.

 

In my Outlook:

1) Created an account to retrieve emails from "Spam@****".

2) Created a folder called "THC_Spam".

3) Created a filter to move all emails beginning with the string "***SPAM***" in the subject to the above named folder.

 

When I first set it up, I used this setup exactly. Then I changed it when I was happy that it wasn't catching good email as Spam in the email account I had set up to the following.

 

In cPanel:

1) Create a filer "SpamAssassin Spam Header", "begins with" and then enter "Yes" in the box. Destination "Discard"

 

You will notice that Spam Box is not enabled. This is what is preventing your Spam from being deleted.

 

The other thing you need to do is set your default address in cPanel to :blackhole: which will discard any email sent to your domain for an account that does not exist.

 

This setup will catch better than 90% of your Spam. I also use a client side program called K9 (http://keir.net/k9.html) which is free to catch the rest of the mail. K9 sits between your email client and the server and uses Bayes filtering to mark email you consider to be spam. You can redirect the ones K9 marks as spam to a separate folder in your email client or directly to your trash folder. K9 is a Windows program.

 

Hope this helps.

Edited by TCH-Bruce
Link to comment
Share on other sites

Hi,

 

Thanks for the advice. I have set up the filter you mentioned and my Spam Box is enabled. All mail marked as Spam is going into the Spam folder in Horde but it is not being deleted - it is like the filter doesn't exist. So, I guess my question is why isn't it working when I seem to have everything set up properly?

 

The rest of the instructions are great.

 

Thanks for your help.

 

Kim

Link to comment
Share on other sites

Ok - now I have another question. I have my mail email account and have set up all unrouted mail to go to blackhole. So if something comes to an alias other than my primary account it will be deleted correct? I have, however, done a couple of tests and I don't seem to be getting any mail at all. I was hoping that I wouldn't see the ones with an alias but I would see the ones for my actual account email. I'm confused.

 

Kim

 

Also, I just removed the blackhole until I figure it out because I want mail to get through.

 

I figured this out - the spam wasn't going to my mail account name address. I removed the blackhole and have added filters for the email account aliases that are giving me the most trouble. The filter set up primarily for Spam Assasin, however, still doesn't seem to be working properly.

Link to comment
Share on other sites

I have set up the filter you mentioned and my Spam Box is enabled. All mail marked as Spam is going into the Spam folder in Horde but it is not being deleted - it is like the filter doesn't exist.

See step 4 under In cPanel: DO NOT enable Spam Box

 

This must be turned off for the filter to work.

Link to comment
Share on other sites

Ok - now I have another question.  I have my mail email account and have set up all unrouted mail to go to blackhole.  So if something comes to an alias other than my primary account it will be deleted correct?  I have, however, done a couple of tests and I don't seem to be getting any mail at all.  I was hoping that I wouldn't see the ones with an alias but I would see the ones for my actual account email.  I'm confused.

When you set yout default address to :blackhole: all mail sent to an address you have not defined either as an account or forward will be discarded.

 

Example, you have kim@****** as your email account. You have webmaster@****** set up as a forward to your kim@****** address. Now someone send email to bob@******, this message will be discarded because you don't have an email address or forward defined for it.

 

Also, I just removed the blackhole until I figure it out because I want mail to get through.
Here's a good way to test. Create another email account. You can call it anything you like (garbage@******). Set your default address to this account. Now send email to your domain using real addresses and addresses that don't exist. The ones that don't exist should be going to your garbage account. Once you are satisfied it's working correctly set your default account to :blackhole: and remove the garbage account. The ":" colons are required in front and back of ":blackhole:" for it to work correctly.

 

I figured this out - the spam wasn't going to my mail account name address.  I removed the blackhole and have added filters for the email account aliases that are giving me the most trouble.  The filter set up primarily for Spam Assasin, however, still doesn't seem to be working properly.

 

I only have one filter (the Spam Assassin one).

Link to comment
Share on other sites

Something I do that may be of interest to someone is this:

 

1. Set up filters for web, webmaster, postmaster to go to the trashcan. I don't use those addresses for anything and they are spam magnets anyway.

 

2. Set up the default email to go to my non-TCH email address.

 

3. When I go to a site that I have to give it an email address for ordering something or signing up, I'll use a descriptive name.

 

For instance, if I go to sign up on the Miami Herald website I'll set my email to miamiherald@**** (substituting the real domain of course). Then, when I get junk mail about enlarging my mortgage or keeping my job from receeding I'll see that "Hey! They got my name from the Herald --- those evil ..." Then I have the option to just filter/block miamiherald and I'll never hear from anyone they sold my address to again.

 

It is working great for me - I use Spam Assassin here, on my off-TCH email site and I use K9 on my home pc so my spam is almost nothing and I haven't seen a false hit yet - I'm about ready to delete instead of tag and segregate the emails it's working so well.

 

Hope it helps someane!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...