Jump to content

Win Xp Flipped Out


mike
 Share

Recommended Posts

Hey, guys and gals, any input on this:

 

Did a restart in xp and got " invalid boot.ini" "booting from C:\windows"

 

then I get no icons except the recycle bin.

many of the start menu items say "empty" when I hold the mouse over them.

Others are intact.

However, MANY programs won't run at all unless I go get the .exe from their folders.

 

AVG came up zip,zero, nadda. :goof:

Spybot came up with:

 

common extension hijack: default registry handler.

 

HKEY_CLASSES_ROOT\regfile\shell\open\command\=regedit.exe "%1"

:huh:

I chose not to have spybot fix it because that's exactly what that key says on my wifes xp. hmmmmm :blink:

 

anyone run into this before. I have a sneaky feeling I will have to re-install all those programs???? :unsure:

Link to comment
Share on other sites

Hi mike, didn't we just go thru a boot.ini problem for you? Sounds like a continuation of the previous problem.

 

The boot.ini is the starting point for loading an operating system, it directs the computer to the OS and the partition or drive where its located. If this is corrupt you need to start with that error first. You need to replace or fix the boot.ini before worrying about what spybot finds.

Link to comment
Share on other sites

No. that was a problem with getting online.

 

I agree about starting with the boot.ini but doesn't most of the items in the boot.ini come from installations?

 

a search for the boot.ini file only comes up with boot.ini.backup created january 03 and modified january 04.

 

so I assume I need to rebuild a boot.ini but doesn't that mean alot of re-installs?

under accessories the system tools are now "empty", so I probably need to even re-install xp.??? Do you think that should be a clean install or not necessary?

 

thanks in advance

Link to comment
Share on other sites

mike, no, the installation information you are talking about goes into the registry. The boot.ini is created when XP is first installed and it just contains information on what OS to boot and where it is located.

 

If you have a backup of the boot.ini I would try that first, it may be the quick fix you need.

Link to comment
Share on other sites

Thanks guys. I copied the boot.ini from my wifes xp. I guess it's ok again, but I have no address book, no icons, and alot of the start menu progs have gone to include the system tools.

Is it alright to run the xp install disk again?

 

Rock Sign

Link to comment
Share on other sites

Do you possibly have multiple accounts to log in under? If you logged into a new account the icons and email will be missing because this new account has not been setup with any of this information yet.

 

Cliak on Start and then LOG OFF and then see if there are multiple accounts to log on with, select the original account and see if everything comes back.

Link to comment
Share on other sites

Yep the "show desktop icons" is still checked

Link to comment
Share on other sites

I checked and it's only my account, Madman. It did change the little picture back to the original; so I went to get the picture I had and low and behold ALL of the photo folders are empty.

 

I have a very lot of photo folders and subfolders, and they are all empty. I checked the view and they are set to thumbnails.

 

So there is apparantly a lot more stuff missing than I thought.

Mad!!!

Link to comment
Share on other sites

That looks like the article I need alright, but I looked all over my xp home disk and can't find any recovery console to run the bootcfg.

 

I tried running it from the run command line, but it isn't there.

Does anyone know where on the xp home disk I am missing this

recovery console?

 

thanks

Link to comment
Share on other sites

To install the Recovery Console as a startup option

With Windows running, insert the Setup CD into your CD-ROM drive.

CLick Start and select Run.

Type the following where D: is the CD-ROM drive letter:

D:\i386\winnt32.exe /cmdcons

 

Follow the instructions on the screen.

Notes

 

To run the Recovery Console, restart your computer and select the Recovery Console option from the list of available operating systems.

You must be logged on as an administrator or a member of the Administrators group in order to complete this procedure. If your computer is connected to a network, network policy settings may also prevent you from completing this procedure.

To see the commands available on the Recovery Console, type help at the at the console prompt.

If your computer will not start, you can run the Recovery Console from the Setup CD. See Related Topics for information on running the Recovery Console when your computer will not start.

Link to comment
Share on other sites

:D

thanks, madman, I surely appeciate it and will give her a run.

 

Rock Sign Rock Sign

Link to comment
Share on other sites

Morning! I got the recovery console installed, but it asks for admin password and won't take it.

 

I even went in and changed the password, which works to get into windows but won't take it ( invalid ) when logging into recovery console.

 

What's up with that?

 

thanks. :goof:

Link to comment
Share on other sites

Thanks madman. :)

Link to comment
Share on other sites

Ok. I did all that. Ran the console.

 

chose log on option c:\windows ( the only option )

 

typed bootcfg /rebuild

 

identifier - home1

 

load options - /fastdetect

 

rebooted and chose home1

 

I really didn't see any change. It worked. But same as it did when I simply copied the wife's boot.ini

 

Am I missing something or did I mistakenly think the system would "refind" all the stuff in the "now empty" folders and bring back all the desktop icons?

 

Am I correct in assuming the only way to bring back progs to the desktop and to the start menu is to remove and re-install?

 

thanks for all your help. Rock Sign

Link to comment
Share on other sites

This sounds somewhat familiar to me.

If memory serves me (preferably a turkey n cheese on whole grain)...

The boot.ini file problem, mixed with the loss of icons and files has to do with the registry becoming corrupted and pointing to a Guest-level account, even though all of the consoles and such say that you are on an admin account.

I do not recall how to recover from this, but I do think it was a reinstall... sorry.

 

You could try creating a new Admin-level account and logging on with that, then resetting permissions/ownership on all folders to that account and see what you can see with that.

Link to comment
Share on other sites

Well, it's the first time I have come upon this problem also; but I think you guys are right about the reinstall.

 

Do you recommend "clean".

 

 

Thanks for all the help I really appreciate it. I also learned some good stuff as well in the process so all is not in vain.

 

Rock Sign Rock Sign Rock Sign

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...