Jump to content
Sign in to follow this  
rcymozart

Hotlink Protection

Recommended Posts

Hello all,

 

I turned on the hotlink protection and found that nearly all of my images would not display. So I turned it back off and searched around to see if there was a solution present that would allow hotlink protection to work (as in display images to someone surfing my site, but not to someone who was linking to them externally).

 

From what I found while searching the forums, it seems like hotlink protection is worthless. Everyone I could find who complained that their images would not load was told to turn it off. I could find no solutions that allow hotlink protection to be on and have the images display when browing from the domains allowed.

 

So I'm wondering: is there a solution or am I correct in thinking that the hotlink protection feature is of no real use unless I'd like to have a site that will not display any images. If there is no solution at present, will one be implemented at a point in the near future?

 

Thanks,

 

Robert

www.lifeofrobert.com

 

PS The images that did display with hotlink protection on are not hosted in my domain for obvious reasons. One is a Creative Commons license, the other is a hit tracker.

Share this post


Link to post
Share on other sites

Robert, when you turn on hotlink protection, you need to add all the sites that are authorized to display the images.

that includes your site as well and any sites like a guestbook where you have added your images.

I suggest keeping a copy of that list in a text file,

as from time to time something happens to the .htaccess file and you may need to redo the activation.

Keep in mind as you probably alredy know, that cpanel only shows you a part of your .htacces file, so be careful. I like to keep a copy of .htaccess just in case.

 

I do use hotlink myself, and it works most of the time.

Share this post


Link to post
Share on other sites
Robert, when you turn on hotlink protection, you need to add all the sites that are authorized to display the images.

that includes your site as well and any sites like a guestbook where you have added your images.

I suggest keeping a copy of that list in a text file,

as from time to time something happens to the .htaccess file and you may need to redo the activation.

Keep in mind as you probably alredy know, that cpanel only shows you a part of your .htacces file, so be careful. I like to keep a copy of .htaccess just in case.

 

I do use hotlink myself, and it works most of the time.

Yes, this was done automatically when I went to enable the hotlink protection. Sites such as "http://lifeofrobert.com" and "http://www.lifeofrobert.com" were in the text box listed as "allowed." Is there something else I need to edit as well?

Share this post


Link to post
Share on other sites

Yes, kick it :dance:

 

sometimes it stops working.

As you say, its can be worthless at times.

 

I have to turn it off for a while and then back on later.

But do make a copy of the list as it grow,

because sometime when you turn it off, you lose some of the links.

Share this post


Link to post
Share on other sites

Thanks for the help! :dance:

 

One last questions. How can I download a copy of the .htaccess file? My FTP client doesn't read it and CPanel doesn't seem to have a download function. Any tricks of the trade?

 

I suppose I could make a copy of the file, rename it to something my FTP client can see, and grab it, but it seems there might be a simpler way to do this.

 

The FTP client is SmartFTP. I also tried the Windows default, just in case, and had no luck there either (which wasn't all that surprising). I have access to a Linux machine, so maybe that will have something more likely to work?

 

Thanks again!

 

Robert

Share this post


Link to post
Share on other sites

Click on Tools > Settings > Transfer -> "Directory Listing Options"

 

Enable the options "[-a] Show Hiden Files" & "[-L] Resolve Links"

Share this post


Link to post
Share on other sites

Hotlinking is when another website links directly to one or more of your images or multimedia files and includes it on their web page.

 

Not only is this theft of your intellectual property, but further more, you are paying for the bandwidth used by that site.

Share this post


Link to post
Share on other sites

arvind2100,

 

Once you turn it on, people can still get your photo's and upload them to their server, however they can not link directly to the picture on your site "Bandwidth Theft" but people can not place the graphic from your website on theirs

 

"<img src='http://yoursite.com/dir/file.gif/jpg/png/zip' border='0'></a>" is what it stops people from doing.

 

 

If you have bandwidth missing on your site, with no reason for it to be, then I would turn it on.

Share this post


Link to post
Share on other sites

arvind2100...I cannot seem to get your photo gallery opened up!

 

Anyway...if you have photos in there that you can foresee someone hotlinking to for some reason, then I would recomment using this feature. I enabled it long ago, and although it caused me a couple problems in the beginning, the staff here at TCH helped me through it, and I haven't had a problem since!!

Share this post


Link to post
Share on other sites

yeah i have a little fun with hotlink protection... if someone links to an image off my web server, i give them a banner ad for my site instead B) at least that's worth all the bandwidth hotlinking can cost, and it usually encourages them to take down the link :D

Share this post


Link to post
Share on other sites
Click on Tools > Settings > Transfer -> "Directory Listing Options"

 

Enable the options "[-a] Show Hiden Files" & "[-L] Resolve Links"

Thanks, but these were already enabled. I disabled as well, in case you mis-typed, and .htaccess still did not show on the list. I tried different combinations (one or the other only enabled, both re-enabled, etc.) and still no luck.

 

Any more tips? B)

Share this post


Link to post
Share on other sites

In Tools-Settings-Transfer uncheck the Use MLSD if available box. Restart SmartFTP and it should show hidden files.

Share this post


Link to post
Share on other sites
In Tools-Settings-Transfer uncheck the Use MLSD if available box. Restart SmartFTP and it should show hidden files.

That did the trick. B)

 

Thanks everyone! Rock Sign

 

Robert

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...