Jump to content

Recommended Posts

well that's just it, I need to have something outside of the local host access it. When I try the domain it doesn't work, it says it can't connect. Is there by chance an IP address I can use? That would make it a lot easier.

Link to post
Share on other sites
well that's just it, I need to have something outside of the local host access it.

AH! See, that bit of info wasn't given before.

 

From cPanel, click on Manage MySQL

 

Then under Access Hosts, ADD a new with only a * entered.

 

Then from your remote application, enter host name of the IP address of your site.

 

If you can post more detail here about what application you are using locally to access your remote MySQL db, then maybe someone can get the very specific steps.

Link to post
Share on other sites
  • 2 weeks later...

I have 2 counterstrike servers hosted elsewhere. I need them to access the mysql database I created on TCH. I can't figure out what I should use as my hostname. I tried using my domain (clanmdc.com) and I even used a ping plotter to find the ip address of the TCH server my site is hosted on. Nothing I try works. Here is an example of the file I have to edit to access mysql:

 

amx_mysql_host "clanmdc.com"

amx_mysql_user "mysql username"

amx_mysql_pass "mysql password"

amx_mysql_db "clanmdc_website"

Link to post
Share on other sites

For your host name try your server (ie. server20.totalchoicehosting.com). Your server number can be found right at the top of the cpanel login.

 

You made sure to go into the "Manage Mysql" option and add a * to your access hosts, right?

Link to post
Share on other sites

Have you tried accessing the database using your local client?

 

If not, you might want to try it.

 

I am not sure what platform you run locally but if it is windows you could try using something like MySQL-Front.

 

I found that if I configured my database to allow access from % and then configured MySQL-Front to:

 

server: ****

user: mytchuser_dbuser

password: <the pw for the user above>

database: mytchuser_dbname

 

I was able to get access locally. Once I got that working I was able to setup remote to remote access.

 

One note if you do get it working you might want to change the security from the wildcard % to the actual host ip address as it would be more secure.

 

Hope this helps!

 

Greg Donaldson

Rockville, MD

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...