Jump to content

Fallback Font defaulting to Comic Sans on Windows Machines


Toninelo
 Share

Recommended Posts

I uploaded the same site to two different domains:

Actual site: https://rockethousepictures.com

Beta test site: http://rockethouse.pictures/RHP-NEW

The fonts display great on the test site. But on the "actual" site it defaults to cursive, in this case Comic sans. Which I'm not ok with. Anything but Comic Sans.

Files are exact the same. Here's the code from the style CSS:

__________________________________

/* Fonts */

    /* Open Sans */
    @import url(http://fonts.googleapis.com/css?family=Open+Sans:600italic,400,300,600,700,800);

    /* Open Sans Condensed */
    @import url(http://fonts.googleapis.com/css?family=Open+Sans+Condensed:300,700);

    /* Condiment */
    @import url(http://fonts.googleapis.com/css?family=Condiment);

    /* Playball */
    @import url(http://fonts.googleapis.com/css?family=Playball);

/* Main Styles */

    ::selection {
        background-color: #ececec;
    }
    html, body {
        background: #fff;
        width:100%;
        height:100%;
        padding:0;
        margin-left:0;
        margin-right:0;
        font-family: 'Open Sans', sans-serif;
        -webkit-font-smoothing: antialiased;
    }

    body{
        overflow-x: hidden;
    }

    img {
        -moz-user-select: none;
        -webkit-user-select: none;
        -ms-user-select: none;
        user-select: none;
        -webkit-user-drag: none;
        user-drag: none;
    }

    a,
    a:hover,
    a:active,
    a:focus
    {
        text-decoration:none;
        outline:none;

    }

    h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6{
        font-family: 'Open Sans', sans-serif;
        font-weight:100;
    }

    p{
        margin:0 0 5px;
    }

    .clear{
        clear:both;
    }

    ol, ul{
        list-style:none;
        padding:0;
    }

    b.caret{
        margin:-3px 0 auto 5px;
    }

    .btn{
        outline:none;
        -webkit-transition: all 0.4s;
        -moz-transition: all 0.4s;
        transition: all 0.4s;
    }

    .btn:focus{
        outline:none;
    }

    .btn:active{
        outline:none;
    }

/* Font Classes */

    .condensed{
        font-family: 'Open Sans Condensed', sans-serif;
    }

    .condiment{
        font-family: 'Condiment', cursive;
    }

    .playball{
        font-family: 'Playball', cursive;
    }

______________________________

I tried changing "cursive" to "serif" ... and even added extra fall back fonts but nothing changed. It almost makes me think this could be a server issue...

Any help is much appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...