Jump to content

Wordpress Issues On Tch... Anyone Else?


Recommended Posts


I have several client sites on TCH (each on their own account) on various servers. I have been noticing a couple issues popping up lately that only seem isolated to these TCH hosted sites. Two in the last couple days that are both on the "Halfmoon" server.


1. Running out of memory and getting a white screen. Either on the Front-End or the Back-End login (or both). This is forcing me to add a PHP.ini file to expand the memory to remedy the problem.

2. Losing the TinyMCE editor buttons when editing a page. With the only remedy being to set the " define('CONCATENATE_SCRIPTS', false); " in the wp-config file so that is doesn't Concatenate the Script files in admin.


I have tried to deactivate all plugins and change themes, with no result. I work with a number of clients sites, but this problem always seems isolated to sites that are hosted with TCH. It could be a coincidence but I noticed these problems starting as TCH was making upgrades to their servers recently. But it doesn't happen on every Wordpress site hosted with TCH.

Has anyone else run into this issue on their sites? Any possible fix that I can implement that might help?

As I type this, I'm also wondering if it could be related to PHP version updates. On most of these sites the .htaccess file contains a line:
AddType application/x-httpd-ea-php54 .php .php5 .phtml


Maybe I should delete that or change to php56 ?


Any thoughts are appreciated.

Thanks for your help.

Link to comment
Share on other sites

This can happen if your scripts, plugins or themes need more memory than what is set as default on PHP configuration. To work around this, please log into cpanel - MultiPHP INI Editor. On the Basic Editor, select the domain from the drop down menu (this would set a local php.ini in your public_html directory) and change the memory_limit value to 128M. Click on Apply. This should resolve your issue. If the problem persists, please open a ticket to our desk with the cpanel logins as well as the wordpress admin logins so that we can check it out.


AddType application/x-httpd-ea-php54 .php .php5 .phtml

That entry is set to get your account working on PHP 5.4. As you are aware, PHP upgrades were done across our shared servers, with PHP 5.6 as the new default, but we retained accounts that were on php 5.4 on the old configs to be the same. You are more than welcome to change that to PHP 5.6 provided you ensure your plugins and themes support it and that your wordpress is on the latest version.


There is a tool on cpanel - MultiPHP Manager - which can be used to switch between versions.

Link to comment
Share on other sites

Thanks Balakrishnan,

Your update did help with the memory issue. It looks like I don't really need the php.ini file anymore, in these cases.

But still have the issue with concatenating scripts not working. Usually that points to a script missing something in the code. However, even when I go back to a raw Wordpress install (generic theme and no plugins) still doesn't work. Not a big deal, but probably becomes a performance issue for the site/server. I've only seen it happen on Halfmoon and Clifford.


Thanks again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...