Jump to content

New To Wordpress


Recommended Posts

Hi, I have started a wordpress page where I intend to let visitors ask questions or leave comments.


I did a comment / reply to a post I did for testing.


wordpress makes visitors register with name, email, website so I did that.


I have since removed that entire post but when I go to other posts and click READ MORE,


it displays my name , email, and website.


I can't seem to make it stop doing that.


any help will be greatly appreciated


thanks in advance

Link to comment
Share on other sites

You will run into the auto-complete/auto-fill feature on many forms including WordPress, but you are seeing it because your browser allows it. To deal with this from your browser(Chrome), check out their help section on How to use Autofill.


If you want to deal with this on a code level so it affects everyone you would need to set the autocomplete="off" tag in your forms.

<form action="wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate="" autocomplete="off">
  <p class="comment-form-author">
    <label for="author">Name <span class="required">*</span></label>
    <input id="author" name="author" value="" size="30" aria-required="true" type="text" autocomplete="off">

You can disable this feature for the entire form as shown in Line1 or for just one field as show in Line 4. Your mileage will vary on what and where to edit depending on your theme or potentially the plugins you have in use.


Link to comment
Share on other sites

thanks, Dick. it WAS my autofill.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...