Jump to content
Sign in to follow this  
mfuggle

Support Is Deteriorating

Recommended Posts

I have been a user of Totalchoice hosting for over four years now and have been very satisfied with the facilities and service until the past couple of months when my experience has been less than satisfactory. Let me explain. I have four shared server environments. One of them established over four years ago and progressively upgraded and with that server I have had few issues.

 

I have recently established two shared server environments and on both occasions tried to install a Drupal script provided by DoubleMThemes. This script has installed without problem in an environment that was provisioned maybe a year or more ago. However in the two new environments it fails. On the first occasion about a month ago it took your support staff some days to install this script and stated that the issue was caused by a MySQL setting that needed to be changed. What that setting was is unknown to me. I have just in the last couple of days established a new environment and attempted to install the same script. First up it failed with an Internal Server Error which was corrected. It then failed in the same way as before where the database creation phase fails to create all of the required tables and then a subsequent phase fails as a result. If I return to a clean state the Internal Server Error recurs. Even if I install a vanilla Drupal 7.14 site using Fantastico it fails with an Internal Server Error when I visit the Drupal install.

 

How come this script runs in one server environment, failed in the second environment but was subsequently installed in that environment by your staff and now fails with precisely the same symptoms in the third environment.

 

How do I get these issues resolved permanently? If I have to go through these hoops everytime in need to get a new environment up and running I will need to find another provider.

 

I must say that I am extremely disappointed at the moment and have no easy way of getting technical support that is able to resolve the issue.

Edited by mfuggle

Share this post


Link to post
Share on other sites

I am personally overseeing your ticket and have the tech on duty work with me to fix your problem. The issue is multi fold and I will give you a full update via ticket once we have it set and running.

Share this post


Link to post
Share on other sites

The installation was failing becuase drupal requires a lot of memory to run which is not enabled by default on php configurations. This is to ensure that scripts do not run away with all the resources and it is available to all the users, being a shared server. To override the memory limit you need to put a php.ini file with the following entries

max_execution_time = 600
max_input_time = 600
memory_limit = 256M
post_max_size = 60M
upload_max_filesize = 54M

 


Next you need to make this override available for your site by adding the following entry on your .htaccess file

 

suPHP_ConfigPath /home/your_cpanel_user_name

 


Verify the Options line is as follows

 

Options SymLinksIfOwnerMatch -Indexes +ExecCGI

 


Add the following line below Options entry

 

AddHandler cgi-script .cgi .pl

 


This will make sure your drupal will install and work fine on our settings server settings.

Both these were added to your .htaccess. I belive you tried to reinstall drupal which replaced the .htaccess file which reverted the changes.

We have now installed drupal as well as the themes after making the above said changes to your .htaccess file. I have also replied to your ticket with detailed steps on how this was done so that you know what was done and can install it yourself from hereon. If you still need help with it, we are only happy to assist. :)

Please accept my apologies for the inconveniences caused, I truly undestand it has not been the kind of support you expected from us. I believe I was able to restore your confidence in us.

I can be contacted via tchgurubala (Yahoo!, AIM) if you need me, also notified owner about your complaint.


Share this post


Link to post
Share on other sites

I have read your tickets and your post here on our forums and I totally agree that we failed to perform up to the standards. iIt appears the causes of your issues were from several issues. Instead of taking up so much time I just want you to know that I hear your voice loud and clear and in fact am addressing this in a longer term fashion. We have just hired a new Customer Service manager that will be taking on the role of making sure that things like this simply do not happen.

 

I am thank full for your business and I hope to be able to serve you for many more years in the future.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×