Jump to content
Sign in to follow this  
artician

Mediawiki Assistance

Recommended Posts

Hi,

 

I'm attempting to install MediaWiki. I've read all the threads already present on the forums, but they were not able to help my issue. I've been running my own site for years, but have no actual experience with PHP or other scripting languages. I am hoping that someone can point me in the right direction, because I seem to have encountered a problem that was not mentioned in any prior discussions.

 

What I've done so far:

I created a subdomain on my site, "wiki.mysite.com".

I created an SQL database named "siteusername_wikidb"

I created an SQL username named "siteusername_wikiuser"

I assigned "siteusername_wikiuser" to the "siteusername_wikidb" database.

I copied MediaWiki files to "wiki.mysite.com/wiki"

I changed write permissions on the MediaWiki config folder.

 

I can visit the location I copied the wiki files to, and see the initial welcoming page for installation, however clicking the "setup the wiki" link from the index page returns an internal server error.

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@dev.sidequestinteractive.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

After researching a bit in the forums I saw some advice about adding login and SQL details to some of the PHP files. I was unable to locate some of the files, such as "localhost.php", but attempted to enter the same information into the installer.php file, thinking it might be related. No dice.

 

I'm out of ideas, so I appreciate any help on this.

 

Thank you in advance!

Edited by artician

Share this post


Link to post
Share on other sites

This was just a permission issue, that I have corrected for you. You can continue with the installation now.

 

Please note that php is running as suPHP on the server, and the maximum permission you required for a folder is 755 and a file is 644.

Share this post


Link to post
Share on other sites

It seems like there is still something wrong going on here. I'm now able to access the Installation portion of the Media Wiki setup, however the SQL DB login password won't take when I try to complete the installation.

 

No actual error message is given when this occurs. I click the "InstallMediaWIKI!" button at the bottom of the config page, and the page simply reloads reporting:

"Something's not quite right yet; make sure everything below is filled out correctly."

 

Scrolling through the configuration page, the only fields that are highlighted in error are for "DB Password".

 

I have confirmed the password I input is correct.

I've confirmed the correct naming and spelling for the database and database-user.

 

I did input these values beforehand in my "installer.php", and then uploaded the mediawiki folder to my webserver. Maybe having them hardcoded into the php install file is causing an issue? It's the same value anyway, so I'm uncertain what could be going on. I've tried deleting and recreating the database and user as well.

 

Thanks for any help with this! This really seems like the best, cleanest wiki to use. I was dismayed it wasn't in fantastico.

 

Thanks again!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...