Jump to content
Sign in to follow this  
Lebleu

Uploading To Main Domain

Recommended Posts

How would i upload a folder so that it stays under the main domain for example www.asdf.net rather then www.asdf.net/folder. I know whatever folder goes in public html will create something like the second one.

Share this post


Link to post
Share on other sites

If you want some files to be available under www.asdf.net you need to upload them to the public_html folder (anything below that level will not be available on the web, by the way).

There's no way to upload a folder into /public_html/ and make it available on www.asdf.net because /public_html/ *is* www.asdf.net.

Hope this clarifies it :goof:

Share this post


Link to post
Share on other sites

thing is i cant take apart folder as theres many other folders inside the main nuke one. I remember now how i did it though. I did it buy making it so when u visiting the main domain it would bring u to www.asdf/index.php but i forget how can u help me

Share this post


Link to post
Share on other sites

I'm not sure I understood the problem.

If you upload a file named "index.php" to your /public_html folder, it will automatically be displayed on your browser when you visit www.asdf.com

 

As for the Nuke stuff, you can simply upload the contents of the folder you want to upload, into /public_html. PHP-Nuke and Post-Nuke both have an index.php file that, as I said above, if placed in /public_html will be loaded automatically on the browser when you visit www.asdf.com

 

If that's not the answer to your problem, could you please specify a bit more?

Share this post


Link to post
Share on other sites

If I'm reading this right, I think you are trying to upload PhpNuke to your public_html folder. When you extract all the files for nuke there is a folder named "html". Just upload everything in that folder into public_html folder, then

www.asdf.net would be the same as going to www.asdf.net/index.php

Share this post


Link to post
Share on other sites

ok i did that now i get another worse problem. It tells me this:

 

Fatal error: Call to undefined function: message_die() in /home/deltata/public_html/db/db.php on line 88

 

when i go to www.deltataskforce.net. Im not sure what the problem is, if its possible something wrong with the config.php that could be ebcause it asks for the following things

 

$dbhost = "localhost";

$dbuname = "Lebleu";

$dbpass = "*****";

$dbname = "phpnuke";

$prefix = "nuke";

$user_prefix = "nuke";

 

The prefixes im not sure about so i did not change them from default the rest is how it appears in the mysql datapase except that the word that comes before the names such as deltata_lebleu and deltata_phpnuke i did not include in the uname and dbname if that matters im not sure

Share this post


Link to post
Share on other sites

The problem is within your dbusername and database settings. Both should have your CPanel username append the the front, i.e. deltata_lebleu and deltata_phpnuke. That should solve that part of the problem. Having looked at everything earlier, you might also want tp move all the files from the html directory to your public_html directory if you want the site to load as your main page.

 

The main thing on manually installing PHPNuke is to read the directions carefully. Some of the directories you don't really need to upload to your site. You also will need to load the db info into the database to get it to run. There is a *.sql file you need to import into the db.

Share this post


Link to post
Share on other sites

Well, you do need to include the "deltata_" prefix before the database name but this shouldn't have anything to do with the other error... :D

 

First, change the database name in your config.php:

$dbname = "deltata_phpnuke";

The username doesn't need the "deltata" prefix so you can leave it as it is.

 

Now, regarding the "undefined function" error... have you uploaded every single file needed by the script?

What that error means is that PHP-Nuke wants to call a function (message_die())that should be somewhere it could find it but it doesn't.

 

I'd guess this has something to do with include paths...

What I mean is that PHP-Nuke probably has some configuration option to specify the directory on the server where it's working. Then it builds the paths to the rest of the files it needs based on that configuration option.

If this option was not set correctly, then PHP-Nuke will not be able to load other files it needs, thus not finding the functions it wants to call.

 

If you could post the rest of your configuration file (ommiting all the usernames, passwords and other sensitive data) we'd be able to see if this is the case.

 

EDIT: Scratch that. I just downloaded PHP-Nuke and it has no paths to configure... :)

Edited by borfast

Share this post


Link to post
Share on other sites

It should look like this

 

 

$dbhost = "localhost";

$dbuname = "deltata_Lebleu";

$dbpass = "*****";

$dbname = "deltata_phpnuke";

$prefix = "nuke";

$user_prefix = "nuke";

 

also nuke has a default sitekey, change it for security reasons.

 

$sitekey = "SdFk*fa28367-dm56w69.3a2fDS+e9";

 

just change the the blue text to anything you want and I mean any thing, it can be "maryhadalittlelamb" if you want

Share this post


Link to post
Share on other sites

just to add another voice here, you have to create the database tables also, you can do it by inporting the .sql file in phpmyadmin or you can upload the nuke.sql file to the root folder of your phpnuke site and then use your browser to navigate to it and creat the tables.

 

You also might want to go to www.nukecops.com and grab their analyze file (its on the main page) and upload it and then run it in your browser, it gives a more detailed description of any problems.

Share this post


Link to post
Share on other sites

ok i now did the first step by changing the info in config.php to what it should be i try my site now and i get the following:

 

Warning: main(language/lang-.php): failed to open stream: No such file or directory in /home/deltata/public_html/mainfile.php on line 166

 

Warning: main(): Failed opening 'language/lang-.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/deltata/public_html/mainfile.php on line 166

 

Warning: head(themes//theme.php): failed to open stream: No such file or directory in /home/deltata/public_html/header.php on line 31

 

Warning: head(): Failed opening 'themes//theme.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/deltata/public_html/header.php on line 31

 

Fatal error: Call to undefined function: themeheader() in /home/deltata/public_html/header.php on line 47

 

The old error is not there now but there is alot more new errors

Share this post


Link to post
Share on other sites

The problem you are experiencing is usually a database connection issue. Did you upload analyze from nukecops? What is the link to the site?

Share this post


Link to post
Share on other sites

the site is www.deltataskforce.com i did not do anything but change the config.php so far

Share this post


Link to post
Share on other sites
the site is www.deltataskforce.com i did not do anything but change the config.php so far

I see the site but I should have said what is the address to the nuke install. Sorry my fault.

Share this post


Link to post
Share on other sites

nuke install? The nuke page should be at www.deltataskforce.com/index.php but obviously it isnt working either. When i uploaded it i took all files out of the html folder and uploaded the rest of the loose files and folders inside to the public html

Share this post


Link to post
Share on other sites

upload nukesql.php to the same location as config.php use your browser and go to www.yoursite.com/nukesql.php (if you put the sql file in your root directory) that will create the tables

Share this post


Link to post
Share on other sites

all those errors look like database errors start by:

Go to Cpanel

Open phpMyAdmin

Go to the Structure tab

Scroll down to the end

Click check all

In the pull down box next to it select Drop

Then select Yes

Go to the SQL tab and upload nuke.sql again

then go to http://www.deltataskforce.net/index.php

 

 

also if you have a index.html page it will load befor the index.php when you use the address http://www.deltataskforce.net

 

EDIT:Sorry i didn't realize you had not loades the tables

Share this post


Link to post
Share on other sites

whats the link for nukesql cant find it either

 

hehe cant find a structure tab in phpmyadmin either

Share this post


Link to post
Share on other sites
whats the link for nukesql cant find it either

It should be in the folder you extracted nuke to on your pc . It is in a folder called SQL

 

 

Sorry I assumed you uploaded the tables already

 

Go to Cpanel

Open phpMyAdmin

Go to the SQL tab and upload nuke.sql

then go to http://www.deltataskforce.net/index.php

Share this post


Link to post
Share on other sites

there is no nukesql that i can see there is a sql folder but inside is a sql file called nuke.sql i uploaded that and went to it but only text

Share this post


Link to post
Share on other sites

Hope I didn't freak you out. I found a nuke.sql and imported it into your database. It should be working now.

Share this post


Link to post
Share on other sites

yup yup turns out that phpnuke.org lied and the 6.7 download was actually 6.0 so i had to take it back down again but mike agreed to help me set it back up tommorow thanks for all the help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...