Jump to content
Sign in to follow this  
thehighwaystar

Disabled Hotlinks, Following Link In Firefox Vs. Ie

Recommended Posts

Hi -

 

OK, this is a strange one.

 

I have set up my TCH site with CPanel to not allow hot linking (but to allow direct requests) to image files. This has been fine for a long while (years).

 

I usually use the Firefox browser. If someone sends me an email (say, Yahoo email) with a link to a picture on my site, and can right click on it and open up the picture.

 

If I use IE (IE 7 right now) and try the same thing, I get a Forbidden You don't have permission to access blah blah message. I can directly cut/paste a link into an IE browser window and it works fine.

 

Anyone have a clue to why the difference? :)

 

Thanks

Share this post


Link to post
Share on other sites

Hi thehighwaystar,

 

I am sorry but I have no answer for you but hang on and someone will.

 

Please do not bump threads (since it´s against the forum rules), we mods do read every post. Also, we mods do not have the answer to everything. This is a forum where all members help each other, so just hold on, some time it just takes a little time.

 

As for moving the post, yes we will if we feel it´s not the appropriate forum for the post. If we do, the member will get a message from us stating which post and to where we moved it.

Share this post


Link to post
Share on other sites
If I use IE (IE 7 right now) and try the same thing, I get a Forbidden You don't have permission to access blah blah message. I can directly cut/paste a link into an IE browser window and it works fine.

 

I don't understand what you are saying here. If you click a link in email it won't display but if you paste the link in the address bar it does? Is that what you are saying?

Share this post


Link to post
Share on other sites

Yes, that is correct. To reiterate, if I use the right mouse context menu items Open, Open in New Tab, Open in New Window, then it fails.

 

I noticed that after it fails, if I place my cursor in the address bar and hit Enter, it resolves fine.

 

Copy/Paste into the address bar is OK.

 

Internet Explorer :thumbdown:

Share this post


Link to post
Share on other sites

That's pretty weird and I have not had that issue but then I use Firefox and not IE.

Share this post


Link to post
Share on other sites

I need to try some things to further isolate the problem (i.e. enabling hotlinking via CPanel and see if the problem does not occur) but am behind a firewall here for a while. Will try later and report back!

Share this post


Link to post
Share on other sites

Here's an update: I disabled the hotlink protection, and then of course was able to link to the images.

 

I cycled the setting BACK again to enable hotlink protection, and it now is working correctly.

 

Not really sure how this fixed it. It needed a little kick? I guess I don't want to know. :thumbdown:

Share this post


Link to post
Share on other sites

Here's an update: I disabled the hotlink protection, and then of course was able to link to the images.

 

I cycled the setting BACK again to enable hotlink protection, and it now is working correctly.

 

Not really sure how this fixed it. It needed a little kick? I guess I don't want to know. B)

 

Are you sure that it is working correctly, or is it just loading the images from the cache instead?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...