Jump to content

Wordpress Admin Connex Problems


Recommended Posts

Okay, I need a little help here. I had an old version of WP installed through Fantastico. Yesterday, I upgraded it to 2.8.6 through Fantastico, then upgraded to 2.9 through the WP Admin. I installed some plugins and a couple new themes-I had lots of themes installed from old installation. During the upgrade and theme installs, I kept having connection problems after where I entered Hostname, Username, Password, etc. However, plugins and themes seemed to install okay. But I was having problems using the Widget layout function in the Admin.


I should also mention that two days ago, I set up a subdomain that this will run from. Because I had installed the original files before the subdomain was setup, today I decided to wipe it all out and start from scratch, since I didn't have any posts in it.


So, used Fantastico to completely remove the old install, which also removed the directory associated with the subdomain. Used CPanel File Manager to recreate the directory name for the subdomain, under public_html. Reinstalled WP 2.8.6, using Fantastico, specifying it to run in the root of the subdomain.


Went to the admin via the subdomain url, and told it to auto-upgrade to 2.9. Still ended up with a "Diagnose Connection Problems" screen. Refreshed back to admin and clicked upgrade again and it said it was up to date, which meant the 2.9 upgrade worked.


Then I try to install a couple of extra themes, and the "Diagnose Connection Problem" screen keeps coming up, plus it is not copying or installing any files for that theme to the WP-content folder.


I have used a variety of different formats for Hostname, including servername.tchmachines.com and subdomain.domainname.com and ftp://subdomain.domainame.com. All resulting in the same problem. The successful installs I had yesterday, plus the successful upgrade today were done using servername.tchmachines.com.


I use my Cpanel username and password for the other two entries. Is there something different I should be doing in filling out the WP connection form? Could this be a timeout problem that I can adjust somewhere in WordPress? Any other suggestions? Should I scrap the current install under Fantastico and manually install a clean version of 2.9 under the subdomain folder?


Thanks for any ideas you may have!

Link to comment
Share on other sites

If Wordpress was originally installed using Fantastico, is doing a WP upgrade through the WP Admin panel supported? I ask because I've usually done any upgrades to a new version of Wordpress thru Fantastico.

Edited by kweilbacher
Link to comment
Share on other sites


Well, I finally got all the themes and plugins I wanted for now loaded in, using "localhost". I believe there's some bugginess in the Wordpress 2.9 dashboard and uploading interface. One theme took 4 tries before it was loaded into WP. After the first two failures, I did a temp reset on my permissions for the wp-content, themes, and pluggins folder, setting them to 777. Theme uploads went a bit smoother after that.


After every install, I never got any kind of notification of success and usually the IE "Connex Problem" screen. The plugins went much smoother, giving screens of success results when they were through. When I was done, I went in and locked the permissions back down.


I do realize that upgrading through the WP dashboard won't be noted by Fantastico. I had only planned to use Fantastico for that original install and not use it for future upgrades. It just saved me a bit of time for the initial install. Future upgrades for WP will be done through its own Admin, or manually, or if needed, backing up my custom config'd files and database, doing a fresh install, and importing the old in, which shud not be too hard, if I keep track of any changes I make.


It is a curious thing about how clunky the WP connection interface was with the TCH servers. Yes, I could have done it all manually via FTP, but I wanted to use somsething that was meant to be used. I do know, at one point, I couldn't connect to TCH anything for about 20 minutes around 4:30 to 5:00 pm PST last night. Couldn't get either of my websites up, couldn't get the TCH home page up, couldn't get the forums up. Connection to all other parts of the Internet were okay for me. I run into this for 2-5 minutes on occassion, but this was the first time for a period so long. Was it some kind of outage?


Thanks so much for the responses. Here's hoping that if anyone else is experiencing this with Wordpress 2.9, they'll find this and it will help them.

Link to comment
Share on other sites

The current stable version for Wordpress is 2.9.1, so you may have to upgrade the install again. You should see the upgrade link on top of your dashboard. I never had any issues while on 2.9, the same goes for 2.9.1.


I did a temp reset on my permissions for the wp-content, themes, and pluggins folder, setting them to 777

WP should update and install fine on 755, I always had them so. But please double check that you have set them back to 755 for security reasons.


Some of the things that I have read people do while they find issues with upgrading

  • Delete off the upgrade directory and try again
  • Disable all plugins before upgrade

If you know your way, I would recommend manual installation of scripts rather than rely on Fantastico.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...