Jump to content

Cron Job Runs Here And There


zethon
 Share

Recommended Posts

I've set up a cron job in my CP that is set to run every other hour on the hour.

 

However, some times it doesn't seem to run at all. It logs data into a database so I know when it runs. For examples, overnight last night I see that it ran at 0200, 0400 and then not again until 0800. Here it is 1030 and it didn't run at 1000 as expected.

 

Can someone please shed some light into why this is happening?

 

Interesting observation: when I set it up to run once an hour, it seems to run every hour without a problem. If I set it up to run once a day, it never runs.

 

Thanks!

Edited by zethon
Link to comment
Share on other sites

Also, I do not see any errors in my logs when it doesn't run, nor do I get an email.

 

Another question I have is -- how can I "fake" an error upon the exitting of my script to force the cron job to send me an email? Will a "return 1" suffice?

 

Thanks!

Link to comment
Share on other sites

Well if it doesn't run there is no way you will get an email. But if it is acting erratic and not running when you think it should please open a ticket with the help desk and have the techs look into it.

 

Ok, I will do that. It did seem to run at noon.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...