Jump to content
Sign in to follow this  
ace

Iomega Rev Drive Keep Ejecting

Recommended Posts

I have a Iomega REV 35 USB drive. The drive keep ejecting the disk when it is inserted. I have tried two disks and get the same results. I have flashed the firmware, updated the REV software and even tried it on a different PC. IT just keeps ejecting no matter what I do. If I unplug the USB cable from the computer the cartridge will remain loaded- but as soon as it is plugged into the computer it ejects. I am thinking the drive has gone bad. Suggestion?? Thanks for your help

Share this post


Link to post
Share on other sites
I have a Iomega REV 35 USB drive. The drive keep ejecting the disk when it is inserted. I have tried two disks and get the same results. I have flashed the firmware, updated the REV software and even tried it on a different PC. IT just keeps ejecting no matter what I do. If I unplug the USB cable from the computer the cartridge will remain loaded- but as soon as it is plugged into the computer it ejects. I am thinking the drive has gone bad. Suggestion?? Thanks for your help

 

 

By the way it is running on XP

Share this post


Link to post
Share on other sites

Power supply went bad - replaced it and now the drive is fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×