Jump to content

Iomega Rev Drive Keep Ejecting


ace
 Share

Recommended Posts

I have a Iomega REV 35 USB drive. The drive keep ejecting the disk when it is inserted. I have tried two disks and get the same results. I have flashed the firmware, updated the REV software and even tried it on a different PC. IT just keeps ejecting no matter what I do. If I unplug the USB cable from the computer the cartridge will remain loaded- but as soon as it is plugged into the computer it ejects. I am thinking the drive has gone bad. Suggestion?? Thanks for your help

Link to comment
Share on other sites

I have a Iomega REV 35 USB drive. The drive keep ejecting the disk when it is inserted. I have tried two disks and get the same results. I have flashed the firmware, updated the REV software and even tried it on a different PC. IT just keeps ejecting no matter what I do. If I unplug the USB cable from the computer the cartridge will remain loaded- but as soon as it is plugged into the computer it ejects. I am thinking the drive has gone bad. Suggestion?? Thanks for your help

 

 

By the way it is running on XP

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...