Jump to content
SteveW

Smf 1.1.8 Released (simple Machines Forum)

Recommended Posts

SMF 1.1.8 has been released.

 

Announcement is at http://www.simplemachines.org/community/in...?topic=290608.0

 

Creating a notification subscribtion to the "News and Updates" board in which that announcement is posted should normally be a good way to be notified of SMF updates. However, I haven't received the usual email notifications from that board for the release of 1.1.7 and 1.1.8.

 

As a backup notification method, I created a daily Google Alert for:

SMF 1.1.8 released site:www.simplemachines.org

and it did notify me within 1 day of this release.

Edited by SteveW

Share this post


Link to post
Share on other sites

Question - for the past two upgrades, I haven't been able to do so from the forums package manager. When I try to log in, it says that session verification failed. I know that my username and password are correct, because I signed into control panel with them afterwards.

 

I've always had FTP server as localhost with Port 21. Is that no longer correct?

 

I upgraded through Fantastico last time, but they don't have 1.1.8 available yet.

 

Thanks!

Share this post


Link to post
Share on other sites

When it tells you that session verification failed, I think it's referring to your current login state at the forum, as a separate matter from the Admin area, package manager, etc. I've gotten that a few times, and it's never lasted very long. I can't remember how I resolved it, but I think the one thing I've never done is the one thing it suggests: log out and log back in. However, it is something to try. Also make sure you're not blocking cookies. The things I probably did were: 1) when you get that message, instead of doing something different, just refresh that same page, maybe even a few times, and 2) browse to a couple more pages. Then if you're not already logged in, try logging in.

 

I'll go see what I can find in package manager about your other questions...

 

Ok, localhost and port 21 are correct.

Your username and password would be your cPanel/FTP ones, not your forum ones.

 

So I suspect it should work ok once you get past the "session" issue. As I recall from posts in the SMF community forum, SMF only uses "sessions" (which are a substitute for cookies) for the first few pages you visit in the forum. So, before you try to log in or go to the Admin area, browse to several of your forum pages.

 

-----

 

After you upgrade through package manager (outside Fantastico), Fantastico (when it learns that 1.1.8 is available) is going to complain and possibly send you an email that your SMF version isn't current.

 

When you get that warning (but not before), use cPanel > File Manager to browse to public_html/forum (or your forum home directory).

Find the file fantversion.php, and Edit it. You'll see that it's just a text file.

Change the version shown to 1.1.8. That will make Fantastico happy.

 

The reason you should not edit that file until you get Fantastico's warning is that it thinks the current version is 1.1.7. If you change it to 1.1.8 now, it will detect the mismatch and send you a warning. It's not smart enough to know that 1.1.8 is later than 1.1.7. It only knows that they aren't the same.

Edited by SteveW

Share this post


Link to post
Share on other sites

Sorry to take so long to get back about this. I made sure cookies were being accepted and tried what you said, but it is still giving me the session verification failed error. This is happening on both the websites I own with forums.

 

Anything else I can try? I'm not keen on upgrading manually. Thanks!

Share this post


Link to post
Share on other sites

I found one of your forums and see that it's using 1.1.7. That update apparently created a problem that must be repaired manually for any subsequent updates to work. Please see http://www.simplemachines.org/community/in...?topic=278824.0.

 

What you'll need to do specifically is:

 

Go to cPanel and click on FileManager to launch it.

Use the lefthand pane to navigate to the folder: /public_html/forums/Sources/

In the righthand pane, click on the Packages.php file to highlight it.

At the top of the screen, click the Edit icon to open Packages.php for editing. Depending on your FileManager settings, you might automatically be switched to the editing window, or you might have to switch to its tab manually.

 

[At this point it's a good idea to select and copy all the text from the file, and paste it into a file on your local PC. If anything goes wrong, you can copy and paste this original text back into the file on your server, and be back where you started.]

 

In the FileManager editor... Scroll down about 3 or 4 PgDn's worth to find the lines (at approximately line 148) that say:

 

>// Test install a package.
function PackageInstallTest()
{
global $boarddir, $txt, $context, $scripturl, $sourcedir, $modSettings;

checkSession('request');

 

Except you will probably find that your last line says:

 

checkSession('get');

 

In that line, change the word get to request.

 

At the top of the screen, click Save Changes.

 

Now try going to your forum Admin area and see if the package manager works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...