Jump to content

Recommended Posts

Hi,

The installation instructions for Drupal are written from the command line. I have been trying to follow them by translating them for use through File Manager in CPanel, but its not working, and I really can't say why.

 

Can anyone point me to instructions for installing it on TCH?

 

Thanks

 

Barbara

Link to post
Share on other sites

I have never installed Drupal but from taking a quick look at their installation instructions you should not need to use any command lines, instead:

 

1. Download the package.

 

2. Create database.

 

3. Extract drupal package to a folder on your site you want it.

 

4. Go to your_site.com/drupalfolder (if I don´t not misunderstand the instructions here) and follow the instructions inn your drupal installation.

 

5. Set up cron job.

 

6. Done.

Link to post
Share on other sites

Thanks, TCH-Thomas, I started all over again. Got to the installation script but I get two error messages right after choosing to install in English.

 

1) Register_globals is enabled and Drupal doesn't want it to be. However, the only instructions they give for changing it is by command line.

2) permissions on the default folder aren't set to allow it to create a file. That I do know how to change.

 

TCH-Bruce, I will use Fantastico if I have to. I have read that that is not a good thing to use because it is not up-to-date. But if I can't do it any other way, I will give it a try.

 

Barbara

Link to post
Share on other sites
To turn off register_globals for your account just add the following line to your .htaccess file inside the Drupal folder or public_html.

>php_flag register_globals off

 

What .htaccess file? I have been looking for it all over my file directory. Do I create it? Is it just a text file called ".htaccess" ?

 

Barbara

 

... OK, I went ahead and tried to create the file, however, I get a message that it already exists. But I DO NOT SEE IT! What do I do to see and edit the file?

Edited by goatgirl
Link to post
Share on other sites

You will need to have file manager to show hidden files. To do this, please:

 

1. Log in to cpanel

 

2. Instead of using "File manager" chose "Legacy File manager"

 

3 Check the box saying "Show Hidden Files (dotfiles)"

 

Now you should see the htaccess file and you can download it to your computer and add the:

php_flag register_globals off

 

Reupload the htaccess file and make sure its called .htaccess when uploaded.

Link to post
Share on other sites
TCH-Bruce, I will use Fantastico if I have to. I have read that that is not a good thing to use because it is not up-to-date. But if I can't do it any other way, I will give it a try.

You are correct and normally I tell people to manually install vs. using Fantastico.

Link to post
Share on other sites
You will need to have file manager to show hidden files. To do this, please:

1. Log in to cpanel

2. Instead of using "File manager" chose "Legacy File manager"

 

Did that

 

3 Check the box saying "Show Hidden Files (dotfiles)"

 

Nope, didn't see anything like that. I clicked on "Settings" but its not there, either. I can upload files, create new folders and files, but those are my only options given. I am on a Mac using Safari, would that make a difference?

 

Barbara

Link to post
Share on other sites

There used to be a way to reset the file manager so that you see the dialog window when launching it (that's where the show hidden files is located), but I can't find it and it's not in the Settings function. If you open a ticket with the help desk they can reset the file manager for you so you can see the dialog.

Link to post
Share on other sites
There used to be a way to reset the file manager so that you see the dialog window when launching it (that's where the show hidden files is located),

 

Thanks, Bruce,

 

I missed the part about the dialog window. I kept clicking through it to the file manager. But I see it now.

 

Thanks.

 

Barbara

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...