Jump to content
kscearce

Comcast Changes Port Setting

Recommended Posts

The "lovely" people at Comcast changed the outgoing port on my comcast account from 25 to 587. As a result, I can't send out emails from my TCH website account.

 

I've tried to change the TCH email account setting in Outlook from 25 to 587 but it doesn't work on either setting. While I use Comcast for Inet, if I'm sending out an email via my TCH account, shouldn't it still work on the 25 port? It's really frustrating for me not to be able to use my TCH web account I have set up in Outlook.

 

Suggestions??

Share this post


Link to post
Share on other sites

I'm using Comcast as my ISP, but my mail goes thru the TCH mailservers. You might consider using the setup that TCH recommends here:

http://www.totalchoicehosting.com/help/e_mailpage.htm

 

Just FYI I am using Outlook 2007 and using port 110 for incoming and Port 26 for outgoing. But as I said, I am using the TCH mail servers.

 

Hope you sort it. Comcast is a bit hopeless these days I must admit.

Edited by TCH-Bruce

Share this post


Link to post
Share on other sites
The "lovely" people at Comcast changed the outgoing port on my comcast account from 25 to 587. As a result, I can't send out emails from my TCH website account.

 

I've tried to change the TCH email account setting in Outlook from 25 to 587 but it doesn't work on either setting. While I use Comcast for Inet, if I'm sending out an email via my TCH account, shouldn't it still work on the 25 port? It's really frustrating for me not to be able to use my TCH web account I have set up in Outlook.

 

Suggestions??

 

If you are using the TCH email server for your outgoing email there is no need to change anything. Leave it on port 25. Since you are not using the Comcast server you do not need to make a change.

Share this post


Link to post
Share on other sites

Bob that's only true if they allow email to be sent over port 25 at all. Changing it to port 26 may or may not correct the issue. If they block sending on port 26 it won't work either.

 

I'm not on Comcast so I don't know for sure. If you are, then I apologize for muddying the thread with my babble.

Share this post


Link to post
Share on other sites
Bob that's only true if they allow email to be sent over port 25 at all. Changing it to port 26 may or may not correct the issue. If they block sending on port 26 it won't work either.

 

I'm not on Comcast so I don't know for sure. If you are, then I apologize for muddying the thread with my babble.

 

No problem Bruce, all input is welcome.

 

The way I understand how mail works is that allowing or blocking of ports is at the server level here. Yes Comcast is the ISP and Comcast maybe blocking port 25 but she is accessing the TCH server. She is using Comcast for Internet access to reach the TCH mail server which uses port 25 and should be available. Comcast mail servers have a block on port 25 so she cannot use them for outgoing mail...but she is not going through the Comcast email server.

 

She composes email on her PC and sends it out across the Internet via Comcasts connection. It goes to the TCH mail server and out to its destination through port 25. It never touches the Comcast Mail server to hit the port 25 block. Using Comcast Internet connection and using Comcast mail servers are two different things.

 

I think the port 25/26 problem is more of a Work/Lan issue where the individual is accessing their personal mail through a firewall that can block ports. At home there is no admin with a firewall "protecting" us from the demons on the internet with their firewall rules. So at work we need to play safe and use port 26 and at home port 25 works.

 

And no I am not on Comcast, I'm a company man and choose to use my companies slow Internet access, FIOS :rolleyes1:

 

Yes, I could be wrong here. But this is how I see it, feel free to jump in and correct me if I'm wrong, bottom line is to get someone's mail working again

Share this post


Link to post
Share on other sites

Oh man, I really feel for you and your slow internet connection. Not! :rolleyes1:

 

Yes, you may be correct on the port 25/26 issue. Never thought of it that way.

Share this post


Link to post
Share on other sites

I'm using Comcast as my ISP, as stated above. I use Port 26 to send. I do think Comcast blocks it, but as Bob said... email is routed thru the server. Since she is using TCH servers w/ Outlook then it should work. I use Outlook 2007 w/ mail routed thru the TCH servers with the settings I stated in my above post and mail works for me no problem.

 

I'm just trying to get secure mail to work, now that I can not get to function, but that's a separate post!

Share this post


Link to post
Share on other sites

I've had several calls from clients who are suddenly having problems sending mail through their TCH accounts via Comcast as their ISP. Research turned up the lore out there that Comcast is blocking outgoing port 25. Without telling anyone, by the way. If you've had reason to draw Comcast's attention to your account with them recently they probably blocked yours as well.

 

Changing your Outlook setting to use port 26 for outgoing mail on your TCH account(s) fixes the problem. Until, as Bruce suggests, Comcast blocks that one as well.

Share this post


Link to post
Share on other sites
I've had several calls from clients who are suddenly having problems sending mail through their TCH accounts via Comcast as their ISP. Research turned up the lore out there that Comcast is blocking outgoing port 25. Without telling anyone, by the way. If you've had reason to draw Comcast's attention to your account with them recently they probably blocked yours as well.

 

Changing your Outlook setting to use port 26 for outgoing mail on your TCH account(s) fixes the problem. Until, as Bruce suggests, Comcast blocks that one as well.

 

 

Thanks for that info Jim. Looks like I need to rethink my understanding of how email works.

Share this post


Link to post
Share on other sites

Comcast blocks port 25 when it notices unusual amounts of email coming out via that port on your connection. This is to help in case your computer is infected with a virus, as most only try using port 25.

 

They block it, and send an email to the primary email account on file with that connection telling them it's been blocked. Problem is most people don't read this email address.

 

It only blocks port 25, so switching to port 26 fixes this.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...