Jump to content
OneRedLT4

Joomla Content Management Security Question

Recommended Posts

Some time ago, I set up Joomla so I could learn it and hopefully admin if needed. Lately I'm getting emails about users registering and there shouldn't be. I've noticed that in the global configuration it says that the register_globals is set to On instead of Off and that it's not recommended. I hadn't been able to find out how to have it changed.

 

Today I tried to turn off the option to allow users to register and the change will not stick. I notice the message of "configuration.php is : Unwriteable" at the top and when trying to save the change, there's a message of "An Error Has Occurred! Unable to open config file to write!"

 

Where or how do I get these things changed? It's ridiculous to not even be able to turn off the ability of anyone coming in (and it's probably not even a real person) and register. None of the options on the global configuration page is editable.

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites

Edit the .htaccess[dot htaccess] file inside the Joomla installation folder, and add the following line

php_flag register_globals off

This will turn off register_globals for your account

 

You can change the permission of configuration.php through File Manager or ftp (just navigate to the folder where Joomla installed) by setting it to 777 permission. Be sure to turn back the permission to 644 once the changes made through Joomla.

Share this post


Link to post
Share on other sites

Thanks. The .htaccess file is actually a text file (weird?) but I input the piece without any results. However, the other option of changing the CHMOD did it. I also edited the configuration file in the FTP client where necessary.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...