Jump to content
Sign in to follow this  
WickedlyWise

Unable To Edit .htaccess File

Recommended Posts

I've changed the permissions on my .htaccess file to 777, but am still getting the following errors when I try to update my permalinks structure:

 

You should update your .htaccess now.

 

If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file.

 

I'd welcome any ideas or suggestions. Thank-you

Share this post


Link to post
Share on other sites

Is your WP installation in the root "public_html" folder or in a subdomain folder? Are you changing the permissions of the correct .htaccess file?

 

You could also just copy/paste the permalink structure into the .htaccess file (my preferred method so you don't need to mess with permissions).

Share this post


Link to post
Share on other sites

I installed WP in a subdomain folder called "blog".

 

I'm changing the .htaccess file in the "blog" subdomain folder, right?

 

I downloaded the .htaccess file so I could add the changes myself. There is still a problem though because the blog pages give me a "page not found error", but when I change the permalink structure it back to "default" the blog pages work fine.

 

WP is also still telling me that it can't update the .htaccess file which I don't understand if the permissions have been changed to 777.

 

Do you have any ideas or suggestions?

 

I really appreciate your help,

 

Margie

Share this post


Link to post
Share on other sites

Yes, that should be the correct one. Don't download it to your computer. Use the editor in cPanel to modify it. As for why it's not able to update through WP I'm not sure. Permissions for WP to update it should be set to 666 not 777 but 777 should allow it to work.

 

If you still can't get it to work, please open a ticket with the help desk (link above or in my signature) and ask one of the techs to take a look.

Share this post


Link to post
Share on other sites

Thank-you Bruce. I didn't realize I could edit the file through the cpanel.

 

I already opened a ticket with the help desk and have been going back and forth with them since Wednesday. So far we haven't had much luck.

 

I appreciate your help.

Share this post


Link to post
Share on other sites

I don't know if this will solve your problem but I had a similar one with my WP site. If you add this code above the stuff WP wants in the .htaccess for the permalinks it may work.

 

><IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

 

Give it a try, nothing to lose.

Share this post


Link to post
Share on other sites

I been trying for three days, literally with tears at times, to get a directory listing to appear for one folder on my site. The above code, followed with "Options +Indexes" in the .htaccess file solved it. Thank you. BTW - I strongly suggest never doing this in the "public_html" folder!

Edited by WarmPuppy

Share this post


Link to post
Share on other sites

Thanks for the welcome folks. Still can't believe I have this issue solved from a five year old thread. To me, this is the Internet at it's best.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...