Jump to content

Wordpress Not Allowing Chinese In Posts


Recommended Posts

Is there any way I can place chinese characters into a post?

 

At the moment I can paste in the charaters but once I save the post the text turns into ???????????.

 

What can I do about this?

 

thanks in advance

Andy

Link to post
Share on other sites

I just tested this using WP 2.6.

 

I copied and pasted some Chinese characters from a web page, and I input some Japanese kanji using IME. Both worked fine. I think that the key here is to make sure that your encoding is set to UTF-8. Check your "Encoding for pages and feeds" setting under "Reading Settings".

 

If that is set to UTF-8, and you are still having problems, look at the page source for the following tag:

><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

If it is something other than UTF-8, then the character set is probably hard coded in your template. In that case, check the header.php file for your template, and edit accordingly.

Edited by Bob Crabb
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...