Jump to content
Sign in to follow this  
mooredd

Joomla! Security "register Global Emulation"

Recommended Posts

Hello all,

 

In reading the security stuff about Joomla!, it says to turn off the emulation by editing the globals:

 

see: register globals emulation instructions

 

 

I just upgraded to the latest install: v.1.0.15

and have done both of the following:

1) edited the globals php file in the root to "0" and

2) confirmed that globals is turned off in the global config / server tab in the joomla! admin/back end.

 

And still, I get system info, security warnings, that tell me that globals is still turned on. I also just installed a new component, and it tells me that it won't work because globals is still turned on.

 

?

 

Is this something TCH can help with, or should I go post my issue w/ joomla! forums. I've searched both forums, and no one else has seemed to have this problem.

 

I truly thank anyone in advance for assistance.

 

- D.

Share this post


Link to post
Share on other sites

Add the following line to the .htaccess file in the root directory:

 

>php_flag register_globals off

 

Then, even though it is turned on in the server, it will be turned off on your site.

Share this post


Link to post
Share on other sites

thanks, Bob; I added the code but it didn't change the warning messages

 

other ideas?

 

 

 

Add the following line to the .htaccess file in the root directory:

 

>php_flag register_globals off

 

Then, even though it is turned on in the server, it will be turned off on your site.

Share this post


Link to post
Share on other sites

If that didn't do it, open a ticket with the help desk and have them take a look at it for you.

Share this post


Link to post
Share on other sites

One thing to try if you have joomla installed in a sub directory...

I don´t have a joomla installation in a sub directory at the moment so I can´t check it, but I believe you can try adding this line in a htaccess file and place that in the same directory as you have joomla in.

Share this post


Link to post
Share on other sites

thanks for all the ideas;

before I submit a ticket, is there a best place to put this line of code in the htacess file?

 

I stuck it between the last two sections, not surrounded by "#s"

 

I have Joomla! installed in the root directory.

 

thanks again.

 

One thing to try if you have joomla installed in a sub directory...

I don´t have a joomla installation in a sub directory at the moment so I can´t check it, but I believe you can try adding this line in a htaccess file and place that in the same directory as you have joomla in.

Share this post


Link to post
Share on other sites

I would try putting it in a separate line, above everything else in your .htaccess file

Share this post


Link to post
Share on other sites

Thanks again; no luck :)

 

I'm submitting a ticket and will let you know how it turns out.

 

- D.

 

I would try putting it in a separate line, above everything else in your .htaccess file

Share this post


Link to post
Share on other sites

Have you tried restarting your apache server, for the effect to take affect. Just a thought.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...