Jump to content

Where Is The "spam Box" For Spamassassin?


Probedude
 Share

Recommended Posts

In Cpanel in the SpamAssassin section there is this blurb.

"SpamBox will deliver any emails identified as spam by SpamAssassin into a separate mail folder named "spam". This "spam" folder will fill up and should be emptied regularly."

 

I've activated SpamAssassin, but where is this "spam folder" ??

Using webmail and Horde I don't see any spam folder.

 

Dave

Edited by Probedude
Link to comment
Share on other sites

The spam folder should be created when you get the first spam email.

 

It should appear in Horde alongside your inbox and sent items.

 

Okay, thanks.

Odd that I haven't received any, I used to get a ton with my previous hosting company and I've been 'switched over' for half a week now with the same email accts.

 

Dave

Link to comment
Share on other sites

I've activated SpamAssassin, but where is this "spam folder" ??

Using webmail and Horde I don't see any spam folder.

 

If you have not also enabled the spambox, the spam will not end up there, and therefor no spambox I believe.

By "only" having spamassassin enabled and default address set to :fail: (note both colons), the spam will automaically get deleted if caught by spamassassin.

Link to comment
Share on other sites

If you have not also enabled the spambox, the spam will not end up there, and therefor no spambox I believe.

By "only" having spamassassin enabled and default address set to :fail: (note both colons), the spam will automaically get deleted if caught by spamassassin.

 

Thanks. I do have it enabled and I did setup an email acct specific for putting mis-addressed emails into days ago.

I'll check again in a bit and see if anything has showed up yet.

Link to comment
Share on other sites

OK - if you still have problems, open a ticket - and we'll send some test spam and check it.

 

:shocking:

 

Just kidding.

 

I 'may' have had "autodelete spam" turned on in the SpamAssassin menu of Cpanel. All the other choices has a status of whether it is enabled or not, but this choice doesn't.

 

I did click on "disable autodeletion" so now I'll see if stuff shows up.

 

Dave

Link to comment
Share on other sites

Update: It's fixed, or more appropriately - I can now see the spam folder.

 

My problem was I was looking at all the various email accts I setup from the main hostname CPanel login's webmail acct.

When I go in that way I can peer into each acct's inbox but it wasn't showing the spam folder.

 

When I instead individually log into webmail using the username and password for each of my email accts, then indeed now there is a spam folder with spam in it.

 

Because I don't have a "one stop shopping" webmail ability to peer into each account's folders and move or delete spam, I've turned off using the 'spam box' so that tagged spam can be delivered into Outlook Express and from there I can go through each account and move or delete spam.

 

With OutlookExpress it will remember all the passwords for all my accounts - something I'll never remember if I have to manually log into webmail for each acct on TCH to check the spam folder.

 

Thanks for your help!

Dave

Link to comment
Share on other sites

I´m glad that its has been solved. :)

 

Ooops, spoke too soon.

 

The person that worked on my trouble ticket had to disable auto deletion of the spam - the button on Cpanel didn't work or it kept re-enabling itself.

 

Last night I logged into one of my accounts and saw that I did have spam in the spam folder. I then logged into Cpanel, turned off the spam box function and now this morning I have NO spam in my inbox, in the spam folder, or anywhere for this particular account. The other account that the tech person worked on is working okay - I did get marked emails for that account.

 

Question: the enabling and disabling of SpamAssassin features is for ALL email accounts correct? Well it appears it's fixed for one of my accounts but not the others.

 

Time to log another trouble ticket.

Edited by Probedude
Link to comment
Share on other sites

If you want to use SpamAssassin and not use Spam Box, but have spam sent to a spam-receiving email address instead, I believe there must also be an email filter set up for that purpose.

 

1) Turn on SpamAssassin, but don't enable Spam Box.

2) Create an email account for spam, something like spam@yourdomain.

3) Go to cpanel > Email > Email Filtering > Add Filter.

 

There might be "Hint" at the bottom of that page:

Hint: To filter all mail that SpamAssassin has marked as spam, just choose "SpamAssassin Spam Header", "begins with", and then enter "Yes" in the box.

 

4) Enter your spam address as the destination, and click Activate.

 

If you previously had a filter, at least check it's still there in case all the spam box on/off fiddling might have deleted it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...