Jump to content
waynej

Tch Rejecting Incoming Emails With .eml Attachments?

Recommended Posts

I've suddenly noticed that if I send an email with a .eml attachment (which is how Thunderbird forwards messages), TCH is apparently rejecting that incoming email. I believe this is new behavior. It even occurs sending to my login on server78. Why is this happening?

 

Here's an example where I obfuscated my email address and some other things. I send email out (SMTP) via RoadRunner (therefore you see rr.com) but only emails which end up on a TCH server get rejected.

 

Return-path: <>

Envelope-to: MyEmailAddress

Delivery-date: Fri, 07 Sep 2007 08:22:18 -0400

Received: from mailnull by server78.tchmachines.com with local (Exim 4.66)

id 1ITcqo-0002P2-Iy

for MyEmailAddress; Fri, 07 Sep 2007 08:22:18 -0400

X-Failed-Recipients: MyEmailAddress

Auto-Submitted: auto-replied

From: Mail Delivery System <Mailer-Daemon@server78.tchmachines.com>

To: MyEmailAddress

Subject: Mail delivery failed: returning message to sender

Message-Id: <E1ITcqo-0002P2-Iy@server78.tchmachines.com>

Date: Fri, 07 Sep 2007 08:22:18 -0400

 

This message was created automatically by mail delivery software.

 

A message that you sent could not be delivered to one or more of its

recipients. This is a permanent error. The following address(es) failed:

 

MyEmailAddress

This message has been rejected because it has

a potentially executable attachment "test message.eml"

This form of attachment has been used by

recent viruses or other malware.

If you meant to send this file then please

package it up as a zip file and resend it.

 

------ This is a copy of the message, including all the headers. ------

 

Return-path: <MyEmailAddress>

Received: from cdptpa-omtalb.mail.rr.com ([75.180.132.120])

by server78.tchmachines.com with esmtp (Exim 4.66)

(envelope-from <MyEmailAddress>)

id 1ITcqg-0002OZ-DJ

for MyEmailAddress; Fri, 07 Sep 2007 08:22:18 -0400

Received: from [192.168.1.101] (really [71.75.187.141])

by cdptpa-omta02.mail.rr.com with ESMTP

id <20070907122214.OIPR3965.cdptpa-omta02.mail.rr.com@[192.168.1.101]>

for <MyEmailAddress>; Fri, 7 Sep 2007 12:22:14 +0000

Message-ID: <46E14276.1090000@MyDomain>

Date: Fri, 07 Sep 2007 08:22:14 -0400

From: me <MyEmailAddress>

User-Agent: Thunderbird 2.0.0.6 (Windows/20070728)

MIME-Version: 1.0

To: me <MyEmailAddress>

Subject: [Fwd: test message]

Content-Type: multipart/mixed;

boundary="------------090303080505080809010201"

X-Spam-Status: No, score=-1.8

X-Spam-Score: -17

X-Spam-Bar: -

X-Spam-Flag: NO

 

This is a multi-part message in MIME format.

--------------090303080505080809010201

Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Content-Transfer-Encoding: 7bit

 

 

--------------090303080505080809010201

Content-Type: message/rfc822;

name="test message.eml"

Content-Transfer-Encoding: 7bit

Content-Disposition: inline;

filename="test message.eml"

...

Edited by waynej

Share this post


Link to post
Share on other sites

This is actually not a new thing. We have blocked .eml extensions for nearly 4 years now. .eml extensions can contain virus and are nasty little buggers.

 

I am sure one of the mods will dig up the post with all the file extensions that are blocked.

Share this post


Link to post
Share on other sites

Wayne,

 

You can change Thunderbird to use inline forwarding instead of doing so as an attachment. Go to Tools -> Options and then select Composition. At the top is the option to change 'Forward messages' from 'As Attachment' to 'Inline'.

Share this post


Link to post
Share on other sites

Thanks, TCH-Jesse, and everyone else!

 

I now see why I never noticed this before. I recently upgraded from Thunderbird 1.0 to 2.0. The new version forwards an attachment like this:

 

Content-Type: message/rfc822;

name="Re: subject line.eml"

Content-Transfer-Encoding: 7bit

Content-Disposition: inline;

filename="subject line.eml"

 

whereas the old version would forward mail as an attachment like this:

 

Content-Type: message/rfc822;

name="subject line"

Content-Transfer-Encoding: 7bit

Content-Disposition: inline;

filename="subject line"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...