Jump to content

Can't Unzip Via File Manager?

Recommended Posts

I just tried this on my site

I created a zip file,

then in file manager I uploaded it

clicked on the file name and selected extract


I saw

the file name:

File Type: Zip archive data, at least v2.0 to extract

then a list of each file as it was extracted


if this is not working for you then open a help desk ticket to the techs.

Link to comment
Share on other sites

To second what Bruce and Don just said...I just tried Don's test, and the first time I extracted, I got the same message you did, followed by a list of the extracted files. The second time I tried it, I got the same message you did, but no files listed (because the extraction won't overwrite files that exist).

Link to comment
Share on other sites

Bruce, I've done this before, I make my own zip because my folder structure is slightly different from what's in the official zip, upload and un-archive, and voila, it overwrites.


Don, I get the exact same message, but no list of extracted files. I can see them with 'show contents' but they will not extract. I will test another zip file to be sure then open a ticket.



Link to comment
Share on other sites

Spoke too soon.


Just broke my site.


I have done this many times before.


I have backups, root and database. They are valid.


I carefully deleted the files as instructed here: http://codex.wordpress.org/Upgrading_WordPress_Extended and I took all the preliminary steps including disabling plugins.


Again I have done this many times. I used FileZilla to delete the files.


I then extracted the archive, which worked perfectly.


I then attempted to run the upgrade script, and was told I had insufficient permissions. Verified the file was there via CPanel file manager, even clicked the link to open the page right from there, no dice.


So I deleted what I uploaded, restored my local backup, and now I get this:


Warning: main(/home/lwwtmlws/public_html/wp-includes/wp-db.php) [function.main]: failed to open stream: Permission denied in /home/lwwtmlws/public_html/wp-settings.php on line 100


Fatal error: main() [function.require]: Failed opening required '/home/lwwtmlws/public_html/wp-includes/wp-db.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/lwwtmlws/public_html/wp-settings.php on line 100


Restored my database via CPanel, no dice. Same error.


Is this something easy before I enter a ticket?



Link to comment
Share on other sites

Ticket has been entered.


It's a permissions problem.


Apparently everything was CHMOD'd 700 after the unzip via the server. Why? I've never seen that before.


The site is now up but I am painstakingly resetting permissions - for example, I can't log in, but suspect I will be able to shortly.


Self-diagnosis and troubleshooting skillz FTW!

Link to comment
Share on other sites

I have had situations where I have created a directory, upload a zip file and it won't extract into the forum, I select the file and then select extract files here and get nothing at all. So it isn't an isolated case. Yes I understand that someone is talking about unzipping files into existing situation, but it might be related.

Link to comment
Share on other sites

Ownership problems tend to cause what is being seen here. Sometimes the automated tools (Fantastico) will install a package as the web server user (uid 99 - nobody). Another area that this happens with is uploading files through an application other than FTP or CPANEL. Those applications (Joomla, etc.) are running as the user "nobody" and so files uploaded through them are owned by that user.


When the ownership is set as the web server user and the permission are not xx7, you will not have the correct privileges to overwrite the files. This means extracting archives, deleting, or changing permissions will not work.


When this happens the only thing you can do is open a ticket to have the ownership/permissions changed.


It would be nice to have the ability to reset this through cpanel or through a cron job.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...