Jump to content
jayc

Smf Forums

Recommended Posts

Simple Machine Forums

 

I have used both BBPHP and IPB in the past, as well as a number of BBS systems back in the dial up days.

 

I stopped using BBPHP because of the hacking problem and IPB went commercial, one of my basic ground rules is to use open source stuff, and if I put it into a commercial application I donate to the developers, so IPB is out, and frankly it is getting to be too hard to use.

 

Have also tried Joomla and Xoops, but found that as you added functionality with the snap ins, reliablity and interactions between the snapins seemed to be skyrocketing.

 

I have set up a couple of SMF systems now, and am pretty pleased with the core functionality, and the ease of tweaking the skin so I can have a common appearance for the whole site.

 

Net step is to start adding some modules, or Mods in SMF speak, one of the ones that is high on my list is a photo gallery.

 

I have played with both Coppermine and Gallery in the past, but want something that avoids a dual login requirement, and worked better than the Xoops/Coppermine setup.

 

Am trying Gallery for SMF from SMFHacks.com, but running into some problems out of the box.

 

It installs but not completely, it fails to put a menu button on the SMF button, and does not appear on the SMF admin control panels, am wondering if anyone else has tried this mod and might have some clues for me.

 

 

 

Thanks

 

jayr

Share this post


Link to post
Share on other sites

Sorry nobody has answered yet. Don't give up maybe someone will chime in with a solution. Have you checked the SMF forums?

Share this post


Link to post
Share on other sites

Was able to get it working, had to uninstall, reset the theme to the default, re-install. Note that additionally I had to manually update the mods.english.php file.

 

After getting that part done, I had to clone another copy of the default them and put all of my menuing changes back in.

 

Having said that I am pretty satified with it, and the price (free) is certainly within the budget, if my members start to use it I will donate to the developers.

 

Anyone having problems with smfhacks gallery is welcome to contact me for whatever help I might be able to provide.

 

jayr

Share this post


Link to post
Share on other sites
Sorry nobody has answered yet. Don't give up maybe someone will chime in with a solution. Have you checked the SMF forums?

 

Bruce, thanks for the good cheer, but per my note I was able to work through the issues. SMFHacks does have a support area, and was able to find part of the solution there.

 

All in all I am pretty happy with SMF, I have tried both IPB and BBPHP in the past and like SMF much better, seems to have a dedicated support area with a reasonable number of Mods available.

 

of course I will probably run into a problem in the future and end up hating it :) :wallbash: , but for the moment it is what I am going to reccomend to my customers who need a community builder

Share this post


Link to post
Share on other sites

I just setup an SMF forum (actually upgraded from PunBB - very easy to do, I might add).

 

A few people are having problems getting their validation emails.

 

One I know, was on AOL.com, and so I figure it's on AOL's end.

 

Has anybody else had any problems with your software sending out emails to new users and the like?

 

SMF has a formal email/SMTP setup built-in, and I may put in the settings of my domain and see if it works.

 

thanks

austin

Share this post


Link to post
Share on other sites
It could have something to do with the Aol/aim Fowards Policy.

According to this thread I would assume that forums such as SMF are also affected by it.

 

The ban is only on email that is sent from a third party through TCH servers to AOL, which would cover email forwards and mailing lists. Email generated by users of domains that exist on TCH servers (which would include pop/imap users as well as webmail users of TCH accounts) and the software installed on their accounts (such as forums) is not banned.

Share this post


Link to post
Share on other sites
It could have something to do with the Aol/aim Fowards Policy.

According to this thread I would assume that forums such as SMF are also affected by it.

Ok, that's what I'm thinking.

 

SMF has a built-in function to use a formal SMTP mailer rather than the forwarding route that AOL doesn't like (because of the spammers).

 

I'm going to test this, but I believe we can simply put in the SMTP settings of our domain, and the registration/validation emails would then be sent as formal emails from our domain and not the forwarding that AOL, etc., doesn't like. I think .Mac has a problem with some forwards as well.

 

I also found a post on another forum which allows Google mail to be used, which is even better. The validation email would have whatever valid Google address you setup as the return, and it would allow you to easily track the emails that have been sent for validation. Since many forum admins are using GMail these days for their forums, this could be an ideal solution. A ton of storage, and an easy 'search' feature to be able to track down any problems.

Edited by TCH-Bruce
Don't post links to other hosting sites in our forums, thanks.

Share this post


Link to post
Share on other sites

Sorry, didn't mean to link to another hosting site.

 

http://www.simplemachines.org/community/in...p?topic=74237.0 talks about some of the problems people may have with email getting out to new users.

 

http://www.simplemachines.org/community/in...246.0;topicseen gets into another problem that maybe affecting people - the email may not be formatted properly and so is being rejected by certain mail providers.

 

I just tested a solution that works with .Mac ,and wasn't working with .Mac before - went into Feature configuration under Server settings, chose SMTP and then proceeded to add the mail server information:

 

server: mail.yourdomainattch.com

port: 25

smtp username: mailaddress@yourdomainattch.com

smtp password: youremailpassword

 

Worked very fast.

 

For my webmaster email, I have a gmail account. The activation emails received appear to be from my webmaster email gmail account. You can look at the headers, and you'll never see your smtp username account (in my example above, mailaddress@yourdomainattch.com) - you'll see your hosting server name and the mail server, but otherwise it looks like Google.

 

I had somebody test with AOL - didn't work. We'll have to find another solution. We even changed the webmaster address to the mailaddress@yourdomainattch.com thing, thinking that an email that maintains a correct (electronic) paper trail all the way would work.

Share this post


Link to post
Share on other sites

I would make sure their spam filters are not blocking the email from coming in. They should be receiving it without you having to resort to using SMTP to send the welcome email.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...