Jump to content
TCH-Thomas

Apple Quicktime Multiple Vulnerabilities

Recommended Posts

Secunia reports this as Highly critical (http://secunia.com/advisories/24359/).

 

Description:

Some vulnerabilities have been reported in Apple QuickTime, which potentially can be exploited by malicious people to compromise a user's system.

 

1) An integer overflow error exists in the handling of 3GP video files.

 

NOTE: This does not affect QuickTime on Mac OS X.

 

2) A boundary error in the handling of MIDI files can be exploited to cause a heap-based buffer overflow.

 

3) A boundary error in the handling of QuickTime movie files can be exploited to cause a heap-based buffer overflow.

 

4) An integer overflow exists in the handling of UDTA atoms in movie files.

 

5) A boundary error in the handling of PICT files can be exploited to cause a heap-based buffer overflow.

 

6) A boundary error in the handling of QTIF files can be exploited to cause a stack-based buffer overflow.

 

7) An integer overflow exists in the handling of QTIF files.

 

8) An input validation error exists in the processing of QTIF files. This can be exploited to cause a heap corruption via a specially crafted QTIF file with the "Color Table ID" field set to "0".

 

Successful exploitation of the vulnerabilities may allow execution of arbitrary code.

 

Solution:

Update to version 7.1.5.

 

Mac OS X:

http://www.apple.com/quicktime/download/mac.html

 

Windows:

http://www.apple.com/quicktime/download/win.html

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...