Jump to content

Wordpress 2.0 Image Upload


oldhag
 Share

Recommended Posts

I recently upgraded to WP 2.0, and when I attempt to upload images directly from my hard drive, I get this message:

 

"Unable to create directory /home/altehag/public_html/wp-content/uploads/2006/12. Is its parent directory writable by the server?"

 

I created the directory manually, but it still doesn't work. All my directories are set to 777 up to public_html.

 

Is this a host issue? Is support available? I have the same installation on another host and it works fine.

Link to comment
Share on other sites

This is a Wordpress issue. I use Wordpress and hate this change. I have since resorted to using an FTP client to upload my images.

 

Only one folder needs the 777 permissions and that is your upload folder. Changing all your folder permissions to 777 is just asking for trouble.

 

Go into your admin interface for Wordpress, then select Options and then Miscellaneous. Find out what folder is being used for uploads, the default is wp-content/uploads but you can change it. Under the path to upload is a check box to Organize my uploads into month- and year-based folders. If you want your images organized check the box.

 

Then using either the File Manager or an FTP client make sure the root image folder (uploads inside the wp-content folder in this example) is set to 777 permissions. You will then be able to upload through the WP interface.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...