Jump to content
Sign in to follow this  
karlfranz

Server 29 And Adv.guestbook

Recommended Posts

Hello,someone may hate me very much because I have too many question.Sorry very much! shutup

 

I have already found there is a problem between my ISP and server29(my site's server).Every time after I uploaded the upgraded file,I could't see the upgrade while others could see it,even I cleared my tmp dirs and refreshed many times.

So,today I come to library to use the computers here to test my site.I found there are some problems that are not caused by ISP.Just like my guestbook,it's at www.alexsky.com/shctafn25,the problem is...for example,when I first opened the page here at library, I can see the total records is 10,then I wote a comment,the total records is 11 then.After this I went to another URL and came back to my guestbook a few minutes after.I found the total records return to 10,I could see the 11th record by refresh the page.

You may ask me to clean my tmp dirs or this is a bug of adv.guestbook.No,they are not the problem,why?because I also tested the adv.guestbook at the offical homepage(www.proxy2.de).It is no this problem at that adv.guestbook.

That's why I think this may be a strange problem in the server,or may be due to the very distance(I'm in Hong Kong and the server is in USA,I don't want this) :rolleyes: .

If you can,please set up a adv. guestbook at server29 for testing,thank you. Thumbs Up

Share this post


Link to post
Share on other sites

It all seems to look OK from the UK at the moment - every test appeared, with no missing records.

 

I'll have a longer look later

Share this post


Link to post
Share on other sites

I've just posted a test messages and the total records showing was 26 at the time. I then closed the browser, opened a new browser window and typed in the URL again. The record count was still 26. Andy has also tested it and has not experienced any problems with it.

 

Since it works fine here and for Andy too, this does suggest that it's a computer problem over there. As far as we are aware, server29 has no problems on it.

Share this post


Link to post
Share on other sites

Hi,

 

I would think this is a cache problem with either your computer or your ISP. Distance makes no difference.

 

Make sure on your browser that you check automatically for new pages every time you browse

 

Jim

Edited by Jimuni

Share this post


Link to post
Share on other sites

Hi Karl, you now have 32 records.

It worked fine for me.

 

What happens when you click on the guestbook drop down menu at the top right,

what do you see?

Share this post


Link to post
Share on other sites

Hi,thank you for all of you who helped me.<_<

To turtle,when I click on drop down menu, I see Guestbook,21-30,11-20,1-10.

To Jimuni,I have already found there is a problem form my ISP,I know because I couldn't see the newest records even I refreshed the page MANY times at home.That's why I went to library to use the computers there for testing.

In library,when I first open the page,I saw about 15 records(can't remember exactly),then I wrote a comment,so it was 16 records,then I went to another URL(or closed the window),then I came back to my guestbook using the URL bar,the total record was back to 15(not the lastest),but in library I can refresh to see the lastest record.

There are problem with both my computer and the library's,and I believe the problem do not cause by TCH server,so I guess the problem may be the distance.

 

P.S.I also found other problem with my ISP(not about web site),such as I can't open emails from one hotmail account at home,but I can open them at library.Then you may say the problem is my computer,but sorry,I can open emails from other hotmail account,strange?

Share this post


Link to post
Share on other sites

Karl, when you see 21-30 in the drop down menu, and click on go,

do you see records 21-30?

Share this post


Link to post
Share on other sites

It may be a bit complex.

When I first open the guestbook after read your thread,I see 32 records,remember I can't see the lastest record even I refreshed the page at home .

Then I click 21-30,I saw the first one is 31,then I refresh the page,no change,after this I put my mouse on the URL bar and press Enter to reload the page,I saw 33 records,then I click 21-30 again,I finally saw it is exactly 21-30 records.

Share this post


Link to post
Share on other sites

sounds like a cacheing problem to me, I've had problems before where I could go to a website and it would pull up a page that google has cached. On your computer make sure you have it set to check for new page EVERY time a page is visited. That stopped my problems with loading old pages that had been cached.

Share this post


Link to post
Share on other sites

Ok here is the deal.

 

Some ISP's use caching technology. They will take a snapshot of the page you just visited and will save it to their servers hard drive. Why? Think of it this way.

 

If a ISP can save traffic by sending users to a cached content on a hard drive then it speeds up the delivery of pages and consumes less bandwidth.

 

Now most USA isps that cache content only cache the big boys. CNN, ESPN - etc, and they do it early AM and then every 30 minutes or so. But some overseas isps cache content for other reasons, such as content review and restriction. Many ISP's in china do this.

 

So, I think this looks like a ISP cache issue.

 

Bill

Share this post


Link to post
Share on other sites

Yeah...what Bill said....

Share this post


Link to post
Share on other sites

Thank you Head Guru.

But I also tested the adv.guestbook at its offical homepage(www.proxy2.de),I have no this problem with that guestbook,I tested the two guestbook(same version) with the same computer and almost the same time.By the way,I'm in HK and using a HK ISP called HKnet.

Share this post


Link to post
Share on other sites

It still sounds like some sort of caching issue. I tried it from here, and it worked fine. Several other ppl have tried it, and it worked fine for them as well...... That narrows the possibilities quite a bit......

Share this post


Link to post
Share on other sites
Hi,thank you for all of you who helped me.:lol:

To turtle,when I click on drop down menu, I see Guestbook,21-30,11-20,1-10.

To Jimuni,I have already found there is a problem form my ISP,I know because I couldn't see the newest records even I refreshed the page MANY times at home.That's why I went to library to use the computers there for testing.

In library,when I first open the page,I saw about 15 records(can't remember exactly),then I wrote a comment,so it was 16 records,then I went to another URL(or closed the window),then I came back to my guestbook using the URL bar,the total record was back to 15(not the lastest),but in library I can refresh to see the lastest record.

There are problem with both my computer and the library's,and I believe the problem do not cause by TCH server,so I guess the problem may be the distance.

 

P.S.I also found other problem with my ISP(not about web site),such as I can't open emails from one hotmail account at home,but I can open them at library.Then you may say the problem is my computer,but sorry,I can open emails from other hotmail account,strange?

Karl, If I do what you said on your gusetbook,

I see the same thing

I click on the drop down menu select 21-30, click go

I see 21-30, if I click on the url window GO button, it refreshes the 21-30.

I have to click on the drop down menu go button,with the word guestbook (pointer to latest page) showing to see after 31.

Share this post


Link to post
Share on other sites

turtle,if I click the pull down menu,and sectect Guestbook,I can see the lastest record.(remember I can't see the lastest record even refresh the page,but now found I can see it by this method)

Share this post


Link to post
Share on other sites

turtle,do you mean these,

I first open the page,I saw about 15 records(can't remember exactly),then I wrote a comment,so it was 16 records,then I went to another URL(or closed the window),then I came back to my guestbook using the URL bar,the total record was back to 15(not the lastest),but in library I can refresh to see the lastest record.

AndyB and alan have proved they have no this problem.

Share this post


Link to post
Share on other sites

turtle,

No, I mean that if you select a range of records like 1-10 and click GO

then refresh, you will still see 1-10

This is not a bug,I tested it by the offical guestbook at proxy2.de,it is the same.

 

And,do you know what thing caused my problem?

Share this post


Link to post
Share on other sites

A new way to test.

After you post a comment,total record is increased by 1.Then you immediately open a new window and go to my guestbook,can you see that new record?

Share this post


Link to post
Share on other sites

to make sure that IE always loads a new page open IE click tools at the top and then internet options. In the area that it says temporary internet files click on settings, put a check in every visit to the page and click ok.

 

*Disclaimer* If it is your ISP storing cached pages this probably wont help, but it might

Share this post


Link to post
Share on other sites
A new way to test.

After you post a comment,total record is increased by 1.Then you immediately open a new window and go to my guestbook,can you see that new record?

Yes, I do see the new record in a new window.

 

Do you have this problem with my test guestbook?

test guestbook

Share this post


Link to post
Share on other sites

They all work fine for me :-)

 

Maybe I just have a well behaved computer today :lol:

Share this post


Link to post
Share on other sites

Karl, I am on server 5.

This is very strange, mine worked for andy and myself.

Yours works for us,

and yet Liannas works for you.

 

Now I wish i were a drinking man Head Bash

Share this post


Link to post
Share on other sites

Yes,I know it is very strange,but your guestbook may work fine on other computer,I will go to library to test later then report the result to you.

 

P.S. My ISP do cause strange problem,I can't post a new topic with my computer(this topic is posted by a library computer),but I can reply by "Fast REPLY"

Share this post


Link to post
Share on other sites

Hi,

 

This sounds more like IE 6.0 then anything else. I have been having huge problems recently where IE 6.0 crashes, fails to open, fails to proceed to the next page and so forth. I know a few other people have had problems too with IE 6.

 

The fact you can Fast reply, but not actually "add reply" would most definitely point the finger at your IE6 and the workings of Windows on your machine.

 

Jim

Share this post


Link to post
Share on other sites

Karl,

 

I have tested this with yours and turtles guestbook, I am unable to recreate the same fault.

 

The only fault I do get, is if I use the drop down menu to select a page so records 30-40 yet there is 44 records, I can't see any records from 41-44. However this is the same for all guestbooks, not just yours.

 

Jim

Share this post


Link to post
Share on other sites

Thank you Jimuni !:lol:

I tested the guestbooks in library.

I think the ISP of the library computers have some problem,almost all the adv.guestbooks(some do not in TCH server) I tested by those computers have the problem I said before(can't see the lastest record),including Lianna's and the offical adv.guestbook,remember I have no problem with these two guestbooks at home.

I asked some friends to test my guestbook,still waiting the result.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...