Jump to content

406 Not Acceptable...


Recommended Posts

I am using wordpress. On some pages/posts, that I write or import, when I attempt to update I get a 406 error stating...

 

Not Acceptable

An appropriate representation of the requested resource /wp-admin/post.php could not be found on this server.

 

 

However, post.php is there, and I can make certain posts. Some say this might be a permissions problem with some HTML in some of my posts. They came to their hosts for a resolution and seemed to solve it. So I am making this post. Some have asked about "Mod Security"

 

Any help, clues, things I can try, permissions I need to change or anything?

Edited by rgtozavb
Link to post
Share on other sites

Try this link which states to update your .htaccess file to include the following.

 

><IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

 

The other link was working when I posted it.

 

Remember to make a backup copy of your .htaccess file before editing it.

Link to post
Share on other sites
Try this link which states to update your .htaccess file to include the following.

 

><IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

 

The other link was working when I posted it.

 

Remember to make a backup copy of your .htaccess file before editing it.

 

 

Awesome, this is exactly what I was looking for. Wordpress support is really lacking. They mention this exact change, but do not say how to do it, just edit your .htaccess file. I will back up and try it, thank you.

Link to post
Share on other sites
  • 4 months later...

Hi TCH,

 

Quick history:

* I am using Windows Live Writer to publish to my blog (and I've used it successfully on other blogs -- hosted on other webhosts -- for several months)

* Yesterday I was able to make my initial post without problems

* Made some changes after that to the sidebar.

 

This morning I'm getting the error message....

 

 

Error attempting to connect to weblog at:

http://www.happyhysterectomy.com/blog/xmlrpc.php

 

The remote server returned an error: (406) Not Acceptable.

 

I added the changes mentioned earlier in this thread to my .htaccess file.

 

 

Now I'm getting:

 

Error attempting to connect to weblog at:

http://www.happyhysterectomy.com/blog/xmlrpc.php

 

The remote server returned an error: (500) Internal Server Error.

 

I AM able to make changes to the blog from within Wordpress itself.

 

I'm not sure if I added the code correctly. Here's what my edited .htaccess looks like...

 

# BEGIN WordPress

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteBase /blog/

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . /blog/index.php [L]

</IfModule><IfModule mod_security.c>

SecFilterEngine Off

SecFilterScanPOST Off

</IfModule>

 

# END WordPress

 

:)

Any suggestions, guys?

 

Thanks,

Sheila

Link to post
Share on other sites

I'm not sure if a line break is required but try starting the second If on it's own line.

 

># BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /blog/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /blog/index.php [L]
</IfModule>

# END WordPress

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

Link to post
Share on other sites

I too had this wordpress problem, and I used the solution posted here (from urbangiraffe) - and it worked.

 

However, after a day or two, my .htaccess file reverts back to the old version without the fix, and I have to do it all over again. Who does this, why, and is there a compromise workaround that works for both parties?

Link to post
Share on other sites
  • 5 weeks later...
Try this link which states to update your .htaccess file to include the following.

 

><IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

 

The other link was working when I posted it.

 

Remember to make a backup copy of your .htaccess file before editing it.

Doesn't that code just disable mod_security?

 

I am having the same error/issue as mentioned above.

 

My software/script support says the error is due to ' misconfigured or overly strict mod_security rules set by your host".

 

Should we disable mod_security or contact TCH support to look at mod_security itself along with the related issues we have been experiencing?

Link to post
Share on other sites
  • 6 months later...

I am really sorry to bump but this was the page Google returned for me first.

 

Okay, my blog is located at www.stevey.stevey.biz, I know stupid double name but I need some help on getting the latest Windows Live Writer to work with my Wordpress blog, I've done some of mods to .htaccess but it still won't work an I get an 500 Internal Server Error when I type in "http://stevey.biz/stevey/xmlrpc.php" on the "Select Provider" step, I have Wordpress 2.3.2.

 

This is how my .htaaccess file looks:

 

># BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /stevey/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /stevey/index.php [L]
</IfModule>

# END WordPress

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<Files xmlrpc.php>
SecFilterInheritance Off
</Files>

 

I've given you all the information I can, please try to help me I've been stuck with this step for about 3 months. This seems like the best forum to ask so I hope you can help.

Link to post
Share on other sites

Well my friend owns my server which as far as I know is private to my website so I'll ask him when I get the chance, I've been trying to get this working for months now, I'll remove that part :)

 

Edit: I checked my cPanel error logs and the problem was that xmlrpc.php was Chmoded at 777 then changing it to 755 did the trick :)

Edited by Stevey
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...