Jump to content

Phpmail() Issue


OJB
 Share

Recommended Posts

Hi there gang

 

Recently I had my MX records moved over to google apps for your domain (GAFYD) so I could offer my members email addresses through google...

 

All has worked perfectly fine, until suddenly I started getting mail to me which was not meant for me. I have a catch-all set up so any mail sent to an address @**** which doesnt exist will be forward onto my account.

 

Now my Invision Power Board sends out emails for topic subscriptions, email changes, PM notifications etc, and someone has set their email address for the forum to their new @**** one. Now every time they get a PM I get the email to my account and they don't.

 

I asked about this on the google site figuring it was a bug in the software, but what I have been informed it is is that the php mail() still believes that my SMTP server is with TCH i guess. Someone there mentioned something about making sure that the local POP server is set to a SmartHost.

 

Now I can't really claim to know anything about POP/SMTP/SmartHosts

 

So does this sound about right to you experts, is there any way I can change the local POP server to be a smarthost? I can set up a ticket but thought I would ask here first before (possibly) making an idiot of myself asking for something I know nothing about.

 

Here is a link to one of the google posts about this subject:

http://groups.google.com/group/hosted-mail...7b8fffb0b587bc/

 

 

Just incase you have to be registered I have attached what is said in a quote below:

 

1

From: mixey -

Date: Thurs, Sep 21 2006 4:47 pm

 

Hi guys!

 

I have similar problem as few people out here, but I didn't find any

solution.

 

I've got php script which use mail() function and mail isn't delivered

anymore :)

 

If I'm changing recipient e-mail in that script to non gmail hosted

email, mail delivery work fine.

 

And I didn't get any luck with which is gmail hosted.

 

Please help if anyone has solution.

 

 

2

From: fagiani

Date: Fri, Sep 22 2006 5:44 am

 

Hi, There's something that you probably didn't realise: Your email

server still thinks it deliveries e-mail to your domain. You can try to

see if that's your case by logging into your former domains POP/IMAP

account and seeing if there are the messages you've sent so far.

To solve this problem I can think basically in two ways:

- Turn off your's SMTP settings to recognize your domain as a local

relay server or;

- Use an alternate SMTP server to relay your e-mail*.

 

* This option may sound dangerous because of SPAM enforcement rules

lately and if you really care you should have updated your SPF record

on your DNS server, etc., so one way to handle that would be having

Google to provide a SMTP server relay based on your own account

authentication user/password.

 

 

3

From: SchaOn

Date: Sat, Sep 23 2006 9:39 pm

 

I was having a similiar issue....

http://groups.google.com/group/hosted-mail...se_thread/thr...

 

I had set my SMTP server up correctly... though, when I would send

something from a form on the server, they would all get directed to

user1 instead of user2, user3, user4, etc (you get the idea).

 

After playing with the server... and finding in the POP server the

ability for it to act as a Smart Host... and setting the POP up as

such, it FINALLY worked!

Link to comment
Share on other sites

just thought I would give an update so any people with potentialy the same issue can see whats gone on

 

 

i contacted the help desk, explained what was going on

 

they then routed my email to an external exchange server which completely resolved the issue

 

so now I can send email from my invision board forum no problems

 

cheers for the help bruce... i guess a moderator can close this if need be....

 

:thumbup1:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...