Jump to content

Awstats Access 3.0


drewneon
 Share

Recommended Posts

Anyone uses AWStats Access 3.0?

 

I followed its install instructions, edited the config.php, but can't login, always wrong password, however, I'm sure the password I input in the config.php is correct.

 

totalchoicehosting.com is the only place I can find from the docs of the script.

 

Please help.

Link to comment
Share on other sites

  • 4 weeks later...

I am having a similar problem. I have installed AWStats Access 3.0 as per the install.txt file, but I cannot login. When I go to <URL>/stats I get the login prompt three times and then receive "Authorization Required" failure screen.

 

Is it possible that other security tweaks / settings on the server are causing problems?

 

The first line of /home/<username>/www/stats/index.php file contains:

require_once('/home/<username>/awstats-access/config.php');

 

/home/<username>/awstats-access/config.php contains:

<?php

$username = "<awstats-access username>"; /* used to access this utility */

$password = "<awstats-access pass>"; /* used to access this utility */

$site = "<domain.com>";

$cpnlusername = "<cpanel username>";

$cpnlpassword = "<cpanel password";

?>

 

Any help / guidance you can offer would be appreciated.

 

Thanks,

Chris

Link to comment
Share on other sites

Ok, I went and downloaded this and tested it on my wife's domain.

  1. I got the awstats-access.zip file from this page.
  2. I unzipped the archive on my computer.
  3. I went into the Access-Awstats folder and zipped up just the stats folder and everything under it.
  4. I uploaded that zip file to the public_html folder.
  5. Opened File Manager and browsed to the public_html folder.
  6. Selected the zip file I uploaded and then extracted the file contents.
  7. Deleted the zip file.
  8. Browsed to the stats folder.
  9. Selected config.php and selected Edit file.
  10. Entered my account information for the variables.
  11. Assigned username and password.
  12. Saved the file.
  13. Exit File Manager.
  14. Went to my URL http://mydomain.ext/stats
  15. Entered the user name and password I assigned.
  16. Viola! Success!

Give it a try. Once you have it working you can move the config.php file out of the stats folder and add the path as instructed to the script.

 

Hope that helps

Link to comment
Share on other sites

Bruce:

 

Thank you for your reply. No joy. I've tried as you suggested, ensuring proper upload mode, but it still doesn't work.

 

I'm not sure if it makes a difference, but the script is being used on a non-TCH host. However, since it appears TCH is the creator of the script, that's why I've come to this forum.

 

Is there any log I can tail to see what might be causing the login error?

 

Are there any specific system security / php / other settings that must / must not be set to make this script work?

 

Regards,

Chris

Link to comment
Share on other sites

As a workaround to this script problem, I have simply used a non-password protected version of the script availalbe at: link removed

 

and then password protected the domain.ext/stats directory using cPanel

 

still not sure why the original awstats-access 3.0 didn't work, someone in another thread mentioned something about mod_security. Would this have something to do with it not working and causing the failed login and 'Authorization Required' errors? If so, how would one fix mod_security to allow the script to work?

 

Regards,

Chris

Link to comment
Share on other sites

I have also edited the link to the script that Bruce posted as the script in that file is not correct. I believe that is were you got your copy and you should download the latest version at http://www.totalchoicehosting.com/help/statisticspage.htm

Thanks Dick. I removed the one I had downloaded and followed the same steps from the one you linked to with the same success.

Link to comment
Share on other sites

  • 9 months later...
Ok, I went and downloaded this and tested it on my wife's domain.
  1. I got the awstats-access.zip file from this page.
  2. I unzipped the archive on my computer.
  3. I went into the Access-Awstats folder and zipped up just the stats folder and everything under it.
  4. I uploaded that zip file to the public_html folder.
  5. Opened File Manager and browsed to the public_html folder.
  6. Selected the zip file I uploaded and then extracted the file contents.
  7. Deleted the zip file.
  8. Browsed to the stats folder.
  9. Selected config.php and selected Edit file.
  10. Entered my account information for the variables.
  11. Assigned username and password.
  12. Saved the file.
  13. Exit File Manager.
  14. Went to my URL http://mydomain.ext/stats
  15. Entered the user name and password I assigned.
  16. Viola! Success!

Give it a try. Once you have it working you can move the config.php file out of the stats folder and add the path as instructed to the script.

 

Hope that helps

 

Hello,

 

Another newbie here...

After searching on this topic, I found this thread about setting up direct access to Awstats...

I have done exactly as described, but no Viola! for me.

 

First off, I am running Mac OSX, using Firefox. (Shouldn't make a difference, but one never knows.)

 

After downloading the Awstats Access file, unzipping it, and then uploaded the Stats folder to public_html, (/public_html/stats) I went into the stats folder and did my editing in config.php as described. (I am not much of a computer person, but this was pretty easy.)

 

I am pretty confident that I entered my username, password, cpnlusername, and cpnlpassword correctly.

 

 

>$username = "myusername"; /* used to access this utility */
$password = "mypassword"; /* used to access this utility */
$site = "www.24gotham.com";
$cpnlusername = "mycpanelusername";
$cpnlpassword = "mycpanelpassword";

 

 

When I went to log in at "http://www.24gotham.com/stats/" I get the following error page:

 

Error: Couldn't open config file "awstats.www.24gotham.com.conf" nor "awstats.conf" after searching in path ".,/home/urbysrvq/tmp/awstats/,/etc/opt/awstats,/etc/awstats,/etc,/usr/local/etc/awstats": No such file or directory

 

- Did you use the correct URL ?

Example: http://localhost/awstats/config=mysite

Example: http://127.0.0.1/cgi-bin/config=mysite

- Did you create your config file 'awstats.www.24gotham.com.conf' ?

If not, you can run "./../../tools/awstats_configure.pl" from command line, or create it manually.

 

Check config file, permissions and AWStats documentation (in 'docs' directory).

 

I don't know what any of this means. I am assuming I entered my site name correctly in "config.php"? Is this the error?

 

To be sure that I am not doing it wrong, I deleted my first attempt, and started over with the same results.

 

Any help is appreciated.

Link to comment
Share on other sites

Thanks, both of you...

 

 

I changed my config.php file to reflect "24gotham.com", but still cannot access my Awstats.

 

 

I log in and instead of the error page, I just get a blank page, when I reload the page, it is still blank. I checked in both Firefox and Safari.

 

I also confirmed my log on info, and checked to make sure I can still access Awstats from my cPanel (which I can).

 

Again, any assistance is appreciated.

 

Thanks...

Link to comment
Share on other sites

  • 2 years later...

Welcome to the forum joker_josue :)

 

I would start over using these directions.

 

  • Get the awstats-access.zip file from this page.
  • Unzipped the archive on your computer.
  • Go into the Access-Awstats folder and zip up just the stats folder and everything under it.
  • Upload that zip file to the public_html folder.
  • Open File Manager and browse to the public_html folder.
  • Select the zip file you uploaded and then extracted the file contents.
  • Deleted the zip file.
  • Browsed to the stats folder.
  • Selected config.php and select Edit file.
  • Enter your account information for the variables.
  • Assign username and password.
  • Save the file.
  • Exit File Manager.
  • Go to your URL http://your-domain.ext/stats
  • Enter the user name and password you assigned.
  • Viola! Success!

Give it a try. Once you have it working you can move the config.php file out of the stats folder and add the path as instructed to the script.

 

Hope that helps

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...