Jump to content

WS_FTP Question


wvcrafted

Recommended Posts

Hello-

 

I know we are supposed to place the content in our Public_html folder, however when I connect to my site via FTP it always defaults to WWW. I have found myself uploading things into that directory several times. Is there a way to get it to open outside of the www directory? Like: one /home/c-panel name/ I would much rahter it open into my c-panel name directory. I have tried setting my WS_FTP up so it will and it doesn't seem to work.

 

Also, what it the purpose of the WWW directory? Seems to be a duplicate of the Public_html folder. Is the contents of the Public folder automatically mapped into WWW? I have had Public_html or WWW on other hosts, but never both so just wondering.

 

Thanks :)

Link to comment
Share on other sites

With WS_FTP you can set the Start In folder to whatever folder you want to start in. /home/yourcpanelname/ sounds like the setting you want. Make sure you check the box "save folder"

 

Think of ./WWW as a map of ./public_html since it is the same logical folder. Since some scripts look for www instead of public_html my guess is this setting is for compatibility with those scripts.

Edited by Kevan
Link to comment
Share on other sites

In the version of WSFTP that I have, you must access the ADVANCED PROPERTIES to get to a tab that says STARTUP. Type in public_html in to the REMOTE SITE FOLDER field. Say ok, then be sure to SAVE your settings. From that point on, you will open within the public_html folder!

 

You can see a screen print of the WSFTP program settings for one of my TCH websites on this page: h**p://www.samisite.com/publish/using_ftp.htm

 

Note that I have used the /public_html and without the slash and both work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...