Jump to content

Xampp & Php4


Chima
 Share

Recommended Posts

Hi, guys!

 

Does anyone know why PHP-SWITCH (in earlier versions of XAMPP) won't work?

 

I've tried XAMPP-win32-1.4.6 and XAMPP-win32-1.4.9 with the same dismal result... PHP-SWITCH insists that Apache is running, no matter how many times I shutdown Apache. I don't understand how more than one instance of Apache can be running on the same port (80).

 

To determine whether or not the problem could be a possible bug in earlier versions of XAMPP, I downlaoded and installed XAMPP-win32-1.5.1; and... surprise, surprise... PHP-SWITCH works exactly as it should [in 1.5.1].

 

BTW, the reason for my insistence on an earlier version of XAMPP (1.4.6 or 1.4.9) is that my target applications (vtigerCRM, etc.) require older versions of PHP and MySQL.

 

At this juncture, I'm still not sure whether or not there's a bug in earlier versions of PHP-SWITCH (XAMPP 1.4.6 and 1.4.9). But I do know it works just fine in XAMPP v1.5.1.

 

Any thoughts, ideas or assitance you might have to offer would be greatly appreciated.

 

Chima.

Link to comment
Share on other sites

Hello chima,

 

Welcome to the forums. If your not sure if its still running, either check in task manager or check your ports that are open.

 

You can of course run the xmapp apache shut down script. If it gives you an error saying its already closed, then php-switch is buggy as you say.

 

I think if memory does serve me correctley, it is buggy

 

JimE

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...